aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/qimageblitz/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/qimageblitz/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/qimageblitz/APKBUILD')
-rw-r--r--unmaintained/qimageblitz/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/unmaintained/qimageblitz/APKBUILD b/unmaintained/qimageblitz/APKBUILD
new file mode 100644
index 0000000000..208748c9e9
--- /dev/null
+++ b/unmaintained/qimageblitz/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=qimageblitz
+pkgver=0.0.6
+pkgrel=0
+pkgdesc="qt image processing library"
+url="http://www.kde.org"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="qt-dev"
+makedepends="$depends_dev cmake automoc4"
+install=""
+subpackages="$pkgname-dev"
+source="ftp://ftp.kde.org/pub/kde/stable/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir -p "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=TRUE \
+ -Wno-dev "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="0ae2f7d4e0876764a97ca73799f61df4 qimageblitz-0.0.6.tar.bz2"
+sha256sums="9f102269dec50641440e23a449df215a0db9efef9a3969939d618c5e78a5010f qimageblitz-0.0.6.tar.bz2"
+sha512sums="dbd506c01622824efdec69640eb95e737d7848fa15d33351084a6499ca2321d7bc08e080d1e443f8ab9015cd2967c10d9b5aa2f3c6eaa7558153821c46133af9 qimageblitz-0.0.6.tar.bz2"