aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/scummvm
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/scummvm
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/scummvm')
-rw-r--r--unmaintained/scummvm/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/unmaintained/scummvm/APKBUILD b/unmaintained/scummvm/APKBUILD
new file mode 100644
index 0000000000..f4e7e84bb5
--- /dev/null
+++ b/unmaintained/scummvm/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=scummvm
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="engine for several graphical adventure games"
+url="http://www.scummvm.org/"
+arch="all"
+license="GPL2"
+depends=""
+makedepends="libogg-dev libvorbis-dev libtheora-dev zlib-dev
+ libpng-dev jpeg-dev glu-dev sdl-dev alsa-lib-dev freetype-dev"
+install=""
+subpackages=""
+source="http://prdownloads.sourceforge.net/scummvm/scummvm-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/scummvm-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ # nasm disabled due to non-pic/pie compatible assembly
+ # dynamic plugins disabled due to sdl built without dlopen
+ ./configure \
+ --prefix=/usr \
+ --enable-all-engines \
+ --enable-release \
+ --disable-nasm \
+ || exit 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="be91bf3fa2f1b44a82c92cfe8c5cc1c8 scummvm-1.7.0.tar.bz2"
+sha256sums="d9ff0e8cf911afa466d5456d28fef692a17d47ddecfd428bf2fef591237c2e66 scummvm-1.7.0.tar.bz2"
+sha512sums="0133feb2df58461fb0e42b1e84cfb309bd964dad239f7ca0c7529edd4f4716895a45491e31597ec6f6d17361b0ce8f73c317399db07a1249b2ab570e4829000e scummvm-1.7.0.tar.bz2"