aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/siege/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/siege/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/siege/APKBUILD')
-rw-r--r--unmaintained/siege/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/unmaintained/siege/APKBUILD b/unmaintained/siege/APKBUILD
new file mode 100644
index 0000000000..f1ad3e9c08
--- /dev/null
+++ b/unmaintained/siege/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=siege
+pkgver=3.0.8
+pkgrel=0
+pkgdesc="HTTP regression testing and benchmarking utility"
+url="http://www.joedog.org/JoeDog/Siege"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="openssl-dev sed"
+install=""
+subpackages="$pkgname-dbg $pkgname-doc"
+source="http://download.joedog.org/siege/siege-$pkgver.tar.gz
+ stdint.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i.orig doc/siegerc.in -e 's/^# logfile = *$/logfile = ${HOME}\/siege.log/'
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ddd2abc8856c58f2495170fe65c34aa6 siege-3.0.8.tar.gz
+c4ee44914937d0395636d2b03f0c6169 stdint.patch"
+sha256sums="b8b5e3e722b75ab2c8a1a51ca25fc58ae599cf78d84e096242ee57622803b297 siege-3.0.8.tar.gz
+f8948f1aa23d0375f2d393f47d993f5b3026d3abe17516fa21f942443e5a6a9a stdint.patch"
+sha512sums="d4f3b4ff715212bf42df10fea968af95397206f878a7b190fe49cd80b7fcb9abd0bf7f57e34106b956c2de2d151c58fb187329ffff4a748f44db9f156b729b94 siege-3.0.8.tar.gz
+2c36dabd634fc700ebcc7aa9ada41a7f8bd6fb87bf57666631b998efc6e6f7b843c0c49e76659d3cd25954b0069838d80618aaa5fef4731bcc26d25a21061328 stdint.patch"