aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/sisctrl/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/sisctrl/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/sisctrl/APKBUILD')
-rw-r--r--unmaintained/sisctrl/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/sisctrl/APKBUILD b/unmaintained/sisctrl/APKBUILD
new file mode 100644
index 0000000000..584e35926b
--- /dev/null
+++ b/unmaintained/sisctrl/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=sisctrl
+pkgver=0.0.20051202
+pkgrel=3
+pkgdesc="SiSCtrl is Display Control Panel for XFree86/X.org SiS driver"
+url="http://www.winischhofer.net/linuxsisvga.shtml"
+arch="all"
+license="GPL"
+depends=
+makedepends="pkgconfig gtk+-dev libxxf86vm-dev libxrandr-dev libxinerama-dev
+ libxv-dev"
+subpackages="$pkgname-doc"
+source="http://www.winischhofer.net/sis/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-xv-path=/usr/lib \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/man/man1 \
+ "$pkgdir"/usr/share/pixmaps \
+ "$pkgdir"/usr/share/applications
+
+ install -m 644 sisctrl.1x "$pkgdir"/usr/share/man/man1/sisctrl.1
+ install -m 644 icons/32x32/sisctrl.xpm "$pkgdir"/usr/share/pixmaps
+ install -m 644 icons/16x16/sisctrl.png \
+ "$pkgdir"/usr/share/pixmaps/sisctrl_16x16.png
+ install -m 644 icons/32x32/sisctrl.png \
+ "$pkgdir"/usr/share/pixmaps/sisctrl_32x32.png
+ install -m 644 icons/48x48/sisctrl.png \
+ "$pkgdir"/usr/share/pixmaps/sisctrl_48x48.png
+ install -m 644 extra/sisctrl.desktop "$pkgdir"/usr/share/applications || return 1
+}
+md5sums="d9db755fe9fd40809b5c30d1ab286d62 sisctrl-0.0.20051202.tar.gz"