aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/snorenotify
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/snorenotify
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/snorenotify')
-rw-r--r--unmaintained/snorenotify/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/snorenotify/APKBUILD b/unmaintained/snorenotify/APKBUILD
new file mode 100644
index 0000000000..23f6d8ca9b
--- /dev/null
+++ b/unmaintained/snorenotify/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=snorenotify
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Snorenotify is a multi platform Qt notification framework"
+url="https://github.com/Snorenotify/Snorenotify"
+arch="all"
+license="LGPL3"
+depends=""
+depends_dev="qt-dev"
+makedepends="$depends_dev cmake doxygen"
+install=""
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Snorenotify/Snorenotify/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/Snorenotify-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ mkdir -p "$_builddir"/build
+ cd "$_builddir"/build
+ cmake "$_builddir" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="508dafd77c2cb1b57239c1dc6ad73727 snorenotify-0.5.2.tar.gz"
+sha256sums="105d09fc7bbf2da357046d8227f4530eac4fc027f7a90d0c7dc984b4a337649d snorenotify-0.5.2.tar.gz"
+sha512sums="d86c061d4dbda002391333e62b987690916526866b9dd1904304ef92b314cb2f7812c46477666f22508803fbffeeaabea85f00e65389ffa5041dbc92f2241808 snorenotify-0.5.2.tar.gz"