aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/spectools
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/spectools
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/spectools')
-rw-r--r--unmaintained/spectools/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/spectools/APKBUILD b/unmaintained/spectools/APKBUILD
new file mode 100644
index 0000000000..3c10fe79a8
--- /dev/null
+++ b/unmaintained/spectools/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spectools
+pkgver=201108
+_pkgver=2011-08-R1
+pkgrel=0
+pkgdesc="Utilities for using Wi-Spy USB spectrum analyzer"
+url="https://www.kismetwireless.net/spectools/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev="gtk+2.0-dev bash cairo-dev libusb-compat-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://www.kismetwireless.net/code/$pkgname-${_pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-${_pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ autoreconf --install
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="b742d5c7dec6fbd3c5070e54d43e6570 spectools-2011-08-R1.tar.gz"
+sha256sums="ce981cd2b86c6246dc7cb9c0166b85e586e5f5835d3ed147e8901ef18f00220e spectools-2011-08-R1.tar.gz"
+sha512sums="92c80b34049055cec6d677db165fb2d06d75fbff9f04d41ab81fa57900f639936e6a9a01f06165aea863b35760964016f0984f17816859d054bc9d14353e847b spectools-2011-08-R1.tar.gz"