aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/squidanalyzer
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/squidanalyzer
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/squidanalyzer')
-rw-r--r--unmaintained/squidanalyzer/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/unmaintained/squidanalyzer/APKBUILD b/unmaintained/squidanalyzer/APKBUILD
new file mode 100644
index 0000000000..f61246ed39
--- /dev/null
+++ b/unmaintained/squidanalyzer/APKBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=squidanalyzer
+pkgver=5.2
+pkgrel=0
+pkgdesc="Squid proxy log analyzer and report generator"
+url="http://squidanalyzer.darold.net/"
+arch="noarch"
+license="GPLv3"
+depends="perl"
+depends_dev=""
+makedepends="$depends_dev perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/squid-report/squid-report/$pkgver/squidanalyzer-$pkgver.tar.gz"
+
+_builddir="$srcdir"/squidanalyzer-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL \
+ INSTALLDIRS=vendor \
+ BINDIR=/usr/sbin \
+ MANDIR=/usr/share/man/man3 \
+ HTMLDIR=/var/lib/squidanalyzer \
+ LOGFILE=/var/log/squid/access.log \
+ DESTDIR="$pkgdir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+ install -d "$pkgdir"/etc/periodic/daily
+ echo -e "#!/bin/sh\nexec /usr/sbin/squid-analyzer" \
+ > "$pkgdir"/etc/periodic/daily/squid-analyzer || return 1
+ chmod +x "$pkgdir"/etc/periodic/daily/squid-analyzer || return 1
+
+}
+
+md5sums="f716bbb106bde6c8dbe568a6d6f7d0a7 squidanalyzer-5.2.tar.gz"
+sha256sums="1f708e0c2baeb27e229039372bc80ea10c845495eca2bd8b3b099ce2ea2a244b squidanalyzer-5.2.tar.gz"
+sha512sums="e9b559db7333c2c8ec46a4c46b8b9182c6728f69cbeaf0378ccf2be737a35d8271b736010de23505655dd178e96fde2f8c8d1e4ef5a1dfbd1ba8e552b7f3780a squidanalyzer-5.2.tar.gz"