aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/trayer
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/trayer
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/trayer')
-rw-r--r--unmaintained/trayer/APKBUILD46
-rw-r--r--unmaintained/trayer/makefile.patch23
2 files changed, 69 insertions, 0 deletions
diff --git a/unmaintained/trayer/APKBUILD b/unmaintained/trayer/APKBUILD
new file mode 100644
index 0000000000..3943375108
--- /dev/null
+++ b/unmaintained/trayer/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer:
+pkgname=trayer
+pkgver=1.0
+pkgrel=1
+pkgdesc="A lightweight GTK2-based systray"
+url="https://gna.org/projects/fvwm-crystal/"
+arch="all"
+license="GPL MIT"
+depends=""
+depends_dev="libxmu-dev gtk+2.0-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://download.gna.org/fvwm-crystal/trayer/${pkgver}/${pkgname}-${pkgver}.tar.gz
+ makefile.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i 's/$(LIBS) $(OBJ) $(SYSTRAYOBJ)/$(OBJ) $(SYSTRAYOBJ) $(LIBS) -lX11/' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make -j1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX="${pkgdir}/usr" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+md5sums="e1b0b6464f991f2c296561e377585867 trayer-1.0.tar.gz
+5c1ca3b37ddcbc121a14fcc58406ae5f makefile.patch"
+sha256sums="64f3b7040a7a563ca4b6924efd950f10c928af7f3535b6f4a00f8bbe0b19484d trayer-1.0.tar.gz
+d5891d4eaaec101759c3604bae9974693add7ec89b954acce3230514d4110f4f makefile.patch"
+sha512sums="9903a78a1c185515e87552732449937daa23187d54a3ccbf19bc9fc569d6a440600c879fe78edbea3eff6b66a1f3fc5054d474dfeaca53af3521a6f18b454049 trayer-1.0.tar.gz
+e5147767263a6642c1f1cd79bbffadc950e581fba088e8dc8487aa4f8ea8c035b8fc19a02f19fdf83fad01e7e3e09df5238c99ad962a1cf24ad0d41b33ccdb8c makefile.patch"
diff --git a/unmaintained/trayer/makefile.patch b/unmaintained/trayer/makefile.patch
new file mode 100644
index 0000000000..52981b34fa
--- /dev/null
+++ b/unmaintained/trayer/makefile.patch
@@ -0,0 +1,23 @@
+ # This patchfile was courtesy of the Debian team. Thanks!
+--- Makefile.common
++++ Makefile.common~
+@@ -25,7 +25,7 @@
+ endif
+
+ # -DGTK_DISABLE_DEPRECATED does not work yet
+-CFLAGS += -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
++CFLAGS += -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED
+
+ %.o: %.c
+ $(CC) $(CFLAGS) $(INCS) -c $<
+--- panel.c
++++ panel.c~
+@@ -588,7 +588,6 @@
+ printf(" --height <number>\n");
+ printf(" --SetDockType <true|false>\n");
+ printf(" --SetPartialStrut <true|false>\n");
+- printf(" --RoundCorners <true|false>\n");
+ printf(" --transparent <true|false>\n");
+ printf(" --alpha <number>\n");
+ printf(" --tint <int>\n");
+