aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ttf-gelasio/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ttf-gelasio/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ttf-gelasio/APKBUILD')
-rw-r--r--unmaintained/ttf-gelasio/APKBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/unmaintained/ttf-gelasio/APKBUILD b/unmaintained/ttf-gelasio/APKBUILD
new file mode 100644
index 0000000000..acc5dbb166
--- /dev/null
+++ b/unmaintained/ttf-gelasio/APKBUILD
@@ -0,0 +1,63 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=ttf-gelasio
+pkgver=1.00
+_hgrev=325e7174147acd060cb6dfe982cf57594a180d53
+pkgrel=0
+pkgdesc="Gelasio serif family by Eben Sorkin."
+url="http://code.google.com/p/googlefontdirectory/"
+arch="noarch"
+license="OFL"
+depends="fontconfig"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+# added fontconfig configuration from:
+# https://github.com/bohoomil/fontconfig-ultimate/tree/master/fontconfig_patches/fonts-settings
+source="https://googlefontdirectory.googlecode.com/hg-history/${_hgrev}/ofl/gelasio/Gelasio-Bold.ttf
+ https://googlefontdirectory.googlecode.com/hg-history/${_hgrev}/ofl/gelasio/Gelasio-BoldItalic.ttf
+ https://googlefontdirectory.googlecode.com/hg-history/${_hgrev}/ofl/gelasio/Gelasio-Italic.ttf
+ https://googlefontdirectory.googlecode.com/hg-history/${_hgrev}/ofl/gelasio/Gelasio-Regular.ttf
+ 45-gelasio.conf
+ 90-tt-gelasio.conf"
+
+_builddir="$srcdir"
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname \
+ "$pkgdir"/etc/fonts/conf.avail \
+ "$pkgdir"/etc/fonts/conf.d
+ for i in "$_builddir"/*.ttf; do
+ install -m644 "$i" \
+ "$pkgdir"/usr/share/fonts/$pkgname/ || return 1
+ done
+ for j in "$srcdir"/*.conf; do
+ install -m644 "$j" \
+ "$pkgdir"/etc/fonts/conf.avail/ || return 1
+ cd "$pkgdir"/etc/fonts/conf.d
+ ln -sf /etc/fonts/conf.avail/${j##*/}
+ done
+}
+md5sums="7be1d568c30cf0392e265effc0e8604f Gelasio-Bold.ttf
+d3c8a6d0d785a2774aa93cf061af46bb Gelasio-BoldItalic.ttf
+54575c749906783220bc30cd278d4cb9 Gelasio-Italic.ttf
+bd1bdf873b65bde2d28e5320a441f733 Gelasio-Regular.ttf
+db221f0bcfc0966d96844698d2e25efe 45-gelasio.conf
+66b8a547f14b90df9a3a554ebe3b8f02 90-tt-gelasio.conf"
+sha256sums="e8b793ff02a65fd6a7aa3a728ec107702652eded8725e6358e88b53af34f94c5 Gelasio-Bold.ttf
+cb06803d9b91dbab6d757d07ee454ff7a0c61961f73f53ddc09843596700d0eb Gelasio-BoldItalic.ttf
+04570e56772c08bc7deffdfe148627a027490594dfe3eebda33c5708223dbd1e Gelasio-Italic.ttf
+125d54b532529889d8e3b5cb774190b1e67e8e8a760908269e6318d97157aaa1 Gelasio-Regular.ttf
+fc0fb11fe69cbd05c84dd6be445d78bca629d4c303fca793e04501b98ccf8872 45-gelasio.conf
+de2ddea85e35f951a16bd78257bf978f5514e577fa29831ed84f5985efd3ee9e 90-tt-gelasio.conf"
+sha512sums="393190d2a8d34661d72227d02f4e57663095cef09a0a4d53f4a3b94f7294893c69c81fd99ae8647e7bee49144ef73721ffdacf139bff657926f92bae717ac0c5 Gelasio-Bold.ttf
+373b05d7700dd30be6249580d479acaea99ca41dd8fc7ca64befeaa66d1fb71236ac234d0850788c455b20853b235ca08b0068e75a8bc8f2e7a9400d40ca2005 Gelasio-BoldItalic.ttf
+50a6b7695a5dcebb48f2bdfd92f57bcc6184031d0e37a6432ea1a020ad9c41723d74b45a8a67a57ecf0d2d5a987ac3c3e683ecd041fd939fb28d5273e21fab0f Gelasio-Italic.ttf
+564c85fd4e0440fad56b9d9c252cefdd20b42c662cbffd1bd477c14352cf8bb5ff717706f98333a5bfb05b5b67f375f4049f54b375eaacc775d70f842a5701f0 Gelasio-Regular.ttf
+bb6a18c187a18a220053c13190d2524d630674e617fc63d8a2268212e6708f4dc575f2c65053e19b865ef0a85396a7bc24ab8fe2493e23f249f6f70d907088ae 45-gelasio.conf
+353d00334890d518915e01ba85c3b465669efe4f113a19eb73b37655d35f33fd8c33eeae27ae3fc82238b0c0a0079ae85f5c86e80bb9d7c604a3ea9bed9a3787 90-tt-gelasio.conf"