aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ulib/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ulib/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ulib/APKBUILD')
-rw-r--r--unmaintained/ulib/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/ulib/APKBUILD b/unmaintained/ulib/APKBUILD
new file mode 100644
index 0000000000..7f56536b1b
--- /dev/null
+++ b/unmaintained/ulib/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ulib
+pkgver=1.4.2
+_gitsnapshot=f4cc822edd7797a0dd4b47379f555e05b9ab8990
+pkgrel=1
+pkgdesc="ULib is a highly optimized class framework for writing C++ applications"
+url="https://github.com/stefanocasazza/ULib"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev="openssl-dev pcre-dev linux-headers"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="https://github.com/stefanocasazza/ULib/archive/$_gitsnapshot.tar.gz"
+
+_builddir="$srcdir"/ULib-$_gitsnapshot
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-static=no \
+ || return 1
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="458f67f667e022ef320754e1ec11cab5 f4cc822edd7797a0dd4b47379f555e05b9ab8990.tar.gz"
+sha256sums="ce212c4d4680cff642be84aacf6722a495a322ac497933d286da15b015fbc9db f4cc822edd7797a0dd4b47379f555e05b9ab8990.tar.gz"
+sha512sums="615da26a311666ab18be1ae0e87adbbb615a7b0e27612e2ff6ad5013321dc42fdfab571b7e12002f5c3819502c0ea1dca9648143a932b9d7c5ee616002c1e1b1 f4cc822edd7797a0dd4b47379f555e05b9ab8990.tar.gz"