aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/v8
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/v8
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/v8')
-rw-r--r--unmaintained/v8/APKBUILD77
-rwxr-xr-xunmaintained/v8/v8.pc10
2 files changed, 87 insertions, 0 deletions
diff --git a/unmaintained/v8/APKBUILD b/unmaintained/v8/APKBUILD
new file mode 100644
index 0000000000..15228d72fc
--- /dev/null
+++ b/unmaintained/v8/APKBUILD
@@ -0,0 +1,77 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=v8
+pkgver=3.26.31.15
+pkgrel=3
+pkgdesc="V8 JavaScript/ECMAScript Engine"
+url="http://www.chromium.org/"
+arch="x86 x86_64 arm"
+license="BSD"
+depends="readline icu"
+depends_dev="icu-dev readline-dev"
+makedepends="${depends_dev} python paxmark"
+install=""
+subpackages="$pkgname-dev"
+# look for updates: http://gsdview.appspot.com/chromium-browser-official/?marker=v8-3.30.22.tar.bz2.hashe%40
+source="http://gsdview.appspot.com/chromium-browser-official/v8-$pkgver.tar.bz2
+ v8.pc"
+
+_builddir="$srcdir"/v8-$pkgver
+
+[ "$CARCH" = 'x86' ] && ARCH=ia32
+[ "$CARCH" = 'x86_64' ] && ARCH=x64
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ find build/ test/ tools/ src/ -type f -exec \
+ sed -e 's_^#!/usr/bin/env python$_&2_' \
+ -e 's_^#!/usr/bin/python$_&2_' \
+ -e "s_'python'_'python2'_" -i {} \;
+
+ sed 's/\bpython\b/python2/' -i Makefile build/gyp/gyp
+
+ sed "s/@VERSION@/$pkgver/g" -i "$srcdir/v8.pc"
+}
+
+build() {
+ cd "$_builddir"
+ local paxflags="-m"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+
+ msg "Start building..."
+ build/gyp_v8 -Dv8_enable_i18n_support=1 -Duse_system_icu=1 -Dconsole=readline -Dcomponent=shared_library -Dv8_target_arch=$ARCH -Dwerror= --generator-output=out -f make
+ make -C out builddir=$(pwd)/out/Release BUILDTYPE=Release mksnapshot.$ARCH
+ paxmark "$paxflags" out/Release/mksnapshot.$ARCH
+ make -C out builddir=$(pwd)/out/Release BUILDTYPE=Release
+
+}
+
+package() {
+ cd "$_builddir"
+
+ install -Dm755 out/Release/d8 "$pkgdir"/usr/bin/d8
+ install -Dm755 out/Release/lib.target/libv8.so "$pkgdir"/usr/lib/libv8.so
+
+ install -d "$pkgdir"/usr/include
+ install -Dm644 include/*.h "$pkgdir"/usr/include
+
+ install -d "$pkgdir"/usr/lib/pkgconfig
+ install -m644 "$srcdir/v8.pc" "$pkgdir"/usr/lib/pkgconfig
+
+ install -d "$pkgdir"/usr/share/licenses/v8
+ install -m644 LICENSE* "$pkgdir"/usr/share/licenses/v8
+
+}
+
+md5sums="e206a825dffb468bb5b15ed32786c306 v8-3.26.31.15.tar.bz2
+082724bc560e90d846c0aa441847020c v8.pc"
+sha256sums="1455d3d9d25771d9fc6fdecd33d07133946d3350b4280abb3f5df293a199f718 v8-3.26.31.15.tar.bz2
+2b054309df9af9fb2e3e14527e88360b44745649b4866e592fb357ac90935f5d v8.pc"
+sha512sums="7d980192e34ac668b2847e435bf5939791614c7bb01782a5ec2f217ea30f06b728d21c80fc6e09a5568ead117a93ec450e3fa2a261ee68cdbe25a3d4f0ad0134 v8-3.26.31.15.tar.bz2
+67848ce85a6e4b674cf8775a21e687884530748a0296a2259373636729c9a230a27b7ebfbf5fafff3c1e9c102956246ec4eb744853e564fc8337b42a125aeea8 v8.pc"
diff --git a/unmaintained/v8/v8.pc b/unmaintained/v8/v8.pc
new file mode 100755
index 0000000000..f3e604becf
--- /dev/null
+++ b/unmaintained/v8/v8.pc
@@ -0,0 +1,10 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=/usr/lib
+includedir=${prefix}/include
+
+Name: v8
+Description: V8 JavaScript Engine
+Version: @VERSION@
+Libs: -L${libdir} -lv8 -pthread
+Cflags: -I${includedir}