aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/xcmenu
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/xcmenu
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/xcmenu')
-rw-r--r--unmaintained/xcmenu/APKBUILD44
-rw-r--r--unmaintained/xcmenu/include-fcntl.patch13
2 files changed, 57 insertions, 0 deletions
diff --git a/unmaintained/xcmenu/APKBUILD b/unmaintained/xcmenu/APKBUILD
new file mode 100644
index 0000000000..27c7ec8f17
--- /dev/null
+++ b/unmaintained/xcmenu/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xcmenu
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Lightweight clipboard manager for X"
+url="https://github.com/Cloudef/xcmenu"
+arch="all"
+license="WTFPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libxcb-dev zlib-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/Cloudef/xcmenu/archive/v$pkgver.tar.gz
+ include-fcntl.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="928bbcbd8db964a5e6a2eb5f2a7baae3 xcmenu-0.1.0.tar.gz
+bbe187d0453bf0088c857bd956acd9b4 include-fcntl.patch"
+sha256sums="149e95ce715c77eaa179b4b8df6c499a4570915a5a094b49a7d914e0073097f1 xcmenu-0.1.0.tar.gz
+60ce9cec1ec4eba15d3a7ef832a42154554429db81df7ae472e0f3172e304284 include-fcntl.patch"
+sha512sums="8b2d3958d1d075433f783a100cca773b20c54207114faafbad9de74cdbc16a1113b7fcd6204207af6b6c43871ce14bfc1b1574a998e022909d8d64fd8d82a511 xcmenu-0.1.0.tar.gz
+c01ad7c59bc6a44e488fb3b82b061b6f8b237801eb1b1cbf9285734a3fa2e413e575a10c5215d5b56d3efbe1ee768cb12895cb3c1b75cb4146218b59361bd954 include-fcntl.patch"
diff --git a/unmaintained/xcmenu/include-fcntl.patch b/unmaintained/xcmenu/include-fcntl.patch
new file mode 100644
index 0000000000..fa7b8621fd
--- /dev/null
+++ b/unmaintained/xcmenu/include-fcntl.patch
@@ -0,0 +1,13 @@
+Only in xcmenu-717cd03d66ab03226c1491678e50030844b0c590-patch/: config.h
+Only in xcmenu-717cd03d66ab03226c1491678e50030844b0c590-patch/: xcmenu
+--- xcmenu-717cd03d66ab03226c1491678e50030844b0c590/xcmenu.c
++++ xcmenu-717cd03d66ab03226c1491678e50030844b0c590-patch/xcmenu.c
+@@ -12,6 +12,7 @@
+ #include <unistd.h>
+ #include <zlib.h>
+ #include <xcb/xcb.h>
++#include <fcntl.h>
+
+ #ifdef XCB_UTIL
+ # include <xcb/xcb_util.h>
+Only in xcmenu-717cd03d66ab03226c1491678e50030844b0c590-patch/: xcmenu.o