aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-26 15:07:24 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-26 15:08:41 +0200
commit03c6d215f7f92f73a460800b393860609c692983 (patch)
tree9b143ae4d5a629dd531f637dec2961127c0fd6c4 /unmaintained
parent866998360a3219c795a37990f3e32b7181316f03 (diff)
downloadaports-03c6d215f7f92f73a460800b393860609c692983.tar.bz2
aports-03c6d215f7f92f73a460800b393860609c692983.tar.xz
testing/gumbo-parser: move to unmaintained
This package has not been updated for at least 6 months and no other packages depends on it anymore.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/gumbo-parser/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/gumbo-parser/APKBUILD b/unmaintained/gumbo-parser/APKBUILD
new file mode 100644
index 0000000000..4e87808a6e
--- /dev/null
+++ b/unmaintained/gumbo-parser/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=gumbo-parser
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="HTML5 parsing algorithm implemented as a pure C99 library"
+url="https://github.com/google/gumbo-parser"
+arch="all"
+license="Apache 2.0"
+depends=
+depends_dev=
+makedepends="$depends_dev autoconf automake libtool"
+install=
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/google/$pkgname/archive/v$pkgver.tar.gz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="c6f75c9eda65e897c242f8958a34aed0 gumbo-parser-0.10.1.tar.gz"
+sha256sums="28463053d44a5dfbc4b77bcf49c8cee119338ffa636cc17fc3378421d714efad gumbo-parser-0.10.1.tar.gz"
+sha512sums="bb1fb55cd07076ab6a9f38dc14db50397dbdca9a04ace4895dfba8b8cbc09038a96e26070c09c75fa929ada2e815affe233c1e2ecd8afe2aba6201647cf277d1 gumbo-parser-0.10.1.tar.gz"