aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-25 02:00:52 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-25 10:29:41 +0000
commit04b746d5669a4668556de7e16383017e39e4f339 (patch)
treedad96b6c06bdaf0ea8dc92ab8558db4980f61637 /unmaintained
parentcf45c878e694371ad00372daab62f741a797b5ed (diff)
downloadaports-04b746d5669a4668556de7e16383017e39e4f339.tar.bz2
aports-04b746d5669a4668556de7e16383017e39e4f339.tar.xz
unmaintained/py3-hypothesis: remove in favor of community/py-hypothesis
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py3-hypothesis/APKBUILD29
-rw-r--r--unmaintained/py3-hypothesis/check.py6
2 files changed, 0 insertions, 35 deletions
diff --git a/unmaintained/py3-hypothesis/APKBUILD b/unmaintained/py3-hypothesis/APKBUILD
deleted file mode 100644
index 9f428cd7f7..0000000000
--- a/unmaintained/py3-hypothesis/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
-pkgname=py3-hypothesis
-pkgver=3.28.3
-pkgrel=0
-pkgdesc="Hypothesis is an advanced testing library for Python"
-url="http://hypothesis.works/"
-arch="noarch"
-license="MPL"
-depends="python3 py3-attrs"
-makedepends="python3-dev py3-pytest"
-source="py3-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/$pkgver.tar.gz"
-builddir="$srcdir/hypothesis-python-$pkgver"
-
-build() {
- cd "$builddir"
- python3 setup.py build
-}
-
-check() {
- PYTHONPATH="$builddir/src" pytest-3 check.py
-}
-
-package() {
- cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="402f116c215af4b57f9702b6af716f0b43a0dd8ee75dc609a0c430fb516dccbab57b438a58590259b25e1bbefaae05dfb28eec80242c599864bc352b98b269b5 py3-hypothesis-3.28.3.tar.gz"
diff --git a/unmaintained/py3-hypothesis/check.py b/unmaintained/py3-hypothesis/check.py
deleted file mode 100644
index 1250548c7d..0000000000
--- a/unmaintained/py3-hypothesis/check.py
+++ /dev/null
@@ -1,6 +0,0 @@
-from hypothesis import given
-from hypothesis.strategies import text
-
-@given(s=text())
-def test_decode_inverts_encode(s):
- assert s.encode("UTF").decode("UTF-8") == s