aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 06:19:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 15:03:28 +0000
commit20feeeae481df58c0df10c5be3e5c5058b3b8c72 (patch)
tree3b1cac8788cc3ae8a804cca9cddeb6ac0d9010df /unmaintained
parent53c2cb930c422b5fc5d60a74171e34b23c32b0ef (diff)
downloadaports-20feeeae481df58c0df10c5be3e5c5058b3b8c72.tar.bz2
aports-20feeeae481df58c0df10c5be3e5c5058b3b8c72.tar.xz
unmaintained/paxctl: move from main
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/paxctl/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/unmaintained/paxctl/APKBUILD b/unmaintained/paxctl/APKBUILD
new file mode 100644
index 0000000000..caa0eac4b3
--- /dev/null
+++ b/unmaintained/paxctl/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=paxctl
+pkgver=0.9
+pkgrel=1
+pkgdesc="Manage PaX related program header flags"
+url="http://pax.grsecurity.net"
+arch="all"
+license="GPL-2.0"
+depends=""
+makedepends=""
+install=
+subpackages="$pkgname-doc"
+source="https://pax.grsecurity.net/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i -e 's:--owner:-o:g; s:--group:-g:g; s:--mode:-m:g' Makefile
+
+ make CFLAGS="$CFLAGS" LDFLASG="$LDFLAGS" || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4048544bd05ed6eb37866034ade8482b8d017110ed9a639f220e8d2e32bb3dfb6c913a986c8fd41829e88efa793f7552eaa2a6d6b2af533c44a5754a5ab8650f paxctl-0.9.tar.gz"