aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-23 07:10:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-23 07:10:51 +0000
commit2e168db253a5cf66d0fb58b40469121207347b06 (patch)
treebd8effdb7d11e1e0af5f99f049dd33b9c685e159 /unmaintained
parent22fe867f12c9b270a510b564be2e008c83229420 (diff)
downloadaports-2e168db253a5cf66d0fb58b40469121207347b06.tar.bz2
aports-2e168db253a5cf66d0fb58b40469121207347b06.tar.xz
testing/singularity: move to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/singularity/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/unmaintained/singularity/APKBUILD b/unmaintained/singularity/APKBUILD
new file mode 100644
index 0000000000..5dd21a1392
--- /dev/null
+++ b/unmaintained/singularity/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Kurt H Maier <khm@sciops.net>
+# Maintainer:
+pkgname=singularity
+pkgver=2.5.1
+pkgrel=1
+pkgdesc="A container platform focused on supporting 'Mobility of Compute'"
+url="http://singularity.lbl.gov/"
+arch="all"
+license="BSD-3-Clause-LBNL"
+depends="python"
+makedepends="autoconf automake libtool linux-headers libarchive-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/singularityware/singularity/releases/download/$pkgver/singularity-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-suid \
+ --with-userns
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0d59561bcb48cd320389821a144c8f8fe852f352a03c6a055a90ccb915c684d5dd0d91462ce55b3cf0cd0a2471c37aefb895e132a842c4552707c9b7835597d0 singularity-2.5.1.tar.gz"