aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-11 16:49:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-12 17:11:41 -0300
commit335cdaa752303ef09d6e7228904e30f91ed1f5cf (patch)
treedeaeafd4e883282d6d223457ed38a86cbc5899f5 /unmaintained
parent657026ebeabfe022b62b69ec37a71c0e9e99dcb8 (diff)
downloadaports-335cdaa752303ef09d6e7228904e30f91ed1f5cf.tar.bz2
aports-335cdaa752303ef09d6e7228904e30f91ed1f5cf.tar.xz
unmaintained/lbzip2: move from testing
- No upstream - Archive link is dead
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/lbzip2/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/lbzip2/APKBUILD b/unmaintained/lbzip2/APKBUILD
new file mode 100644
index 0000000000..1a9d3c6132
--- /dev/null
+++ b/unmaintained/lbzip2/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Justin Menga <justin.menga@gmail.com>
+# Maintainer: Justin Menga <justin.menga@gmail.com>
+pkgname=lbzip2
+pkgver=2.5
+pkgrel=1
+pkgdesc="A parallel bzip2 compression utility"
+url="http://lbzip2.org"
+arch="all"
+license="GPL-2.0-or-later"
+subpackages="$pkgname-doc"
+source="http://archive.lbzip2.org/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install
+}
+sha512sums="76e96cfa75b3ed515b2f891349dffc1403daab2dd0a2a614fa0c811cec6ca25faa395da08ad68a9b6ba4069332c4571f70fb7424f06ef3d800c3082c08d7d3d7 lbzip2-2.5.tar.gz"