aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-01-31 21:52:51 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-31 22:04:03 +0100
commit8371587c8f5ad7e82c82a968a2a77483ee88c74e (patch)
treeef1705f84f6713066b287cfb808ea11341393b73 /unmaintained
parent4ddd06460994ab03441d1ad85a35894d57afb0d3 (diff)
downloadaports-8371587c8f5ad7e82c82a968a2a77483ee88c74e.tar.bz2
aports-8371587c8f5ad7e82c82a968a2a77483ee88c74e.tar.xz
unmaintained/libwnck: move from community
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/libwnck/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/libwnck/APKBUILD b/unmaintained/libwnck/APKBUILD
new file mode 100644
index 0000000000..67c3799a06
--- /dev/null
+++ b/unmaintained/libwnck/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libwnck
+pkgver=2.31.0
+pkgrel=6
+pkgdesc="Window Navigator Construction Kit"
+url="https://git.gnome.org/browse/libwnck"
+arch="all"
+license="LGPL-2.0+"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends=
+makedepends="glib-dev gtk+2.0-dev libx11-dev pango-dev cairo-dev intltool
+ startup-notification-dev gobject-introspection-dev libxres-dev"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/bin/wnckprop \
+ "$pkgdir"/usr/bin/wnck-urgency-monitor
+}
+sha512sums="54262a08882021f08f3ba7f2ddfa33fc1f02e391a0f61cf999a50a089e0d277dfe13ab133c1a46e9abf0599bd24c21dacff80b51013cbb1375d2cd71ac9abbe9 libwnck-2.31.0.tar.xz"