aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-07 08:40:54 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-07 18:28:52 +0000
commitcc71cfc7c67810e2a80b74559f7e50274eeb1183 (patch)
tree65ffe136a8a628f5e44514fa1226c784ae7ab721 /unmaintained
parentd65de9b8864c49b84deb2f1b9a3352995d7fe696 (diff)
downloadaports-cc71cfc7c67810e2a80b74559f7e50274eeb1183.tar.bz2
aports-cc71cfc7c67810e2a80b74559f7e50274eeb1183.tar.xz
unmaintained/libzdb: move from main
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/libzdb/APKBUILD43
-rw-r--r--unmaintained/libzdb/missing-assert.patch13
2 files changed, 56 insertions, 0 deletions
diff --git a/unmaintained/libzdb/APKBUILD b/unmaintained/libzdb/APKBUILD
new file mode 100644
index 0000000000..18ecd0783f
--- /dev/null
+++ b/unmaintained/libzdb/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=libzdb
+pkgver=3.2
+pkgrel=0
+pkgdesc="A thread-safe high level multi-database connection pool library"
+url="http://www.tildeslash.com/libzdb/"
+arch="all"
+license="GPL-3.0-only"
+depends_dev="flex-dev sqlite-dev mariadb-connector-c-dev postgresql-dev"
+makedepends="$depends_dev flex"
+subpackages="$pkgname-dev"
+source="http://www.tildeslash.com/libzdb/dist/libzdb-$pkgver.tar.gz
+ missing-assert.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --enable-optimized \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+check() {
+ cd "$builddir"
+ # The test is manual and requires user input, we spam the dot char
+ # because it is a valid name for the database required by the test
+ # and dot is also the char for exiting the database once test is
+ # complete
+ yes . | make verify
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="b44ee217c0b221812eb2d1be03edcc8e74a5e3907ac3915defc15fa5faf228dac175bd04591fedf5d706773ab85f2dc98cd14c7a84ade5887f4f644d64739824 libzdb-3.2.tar.gz
+4547386470ac74079c41fcec9fb1e4129283982f0b489a2bd57f49586f25e900004ff5d6e61e796eac9ccd35c29e52aae184ec98802b23ad9f216213159b5db2 missing-assert.patch"
diff --git a/unmaintained/libzdb/missing-assert.patch b/unmaintained/libzdb/missing-assert.patch
new file mode 100644
index 0000000000..10e279d3b3
--- /dev/null
+++ b/unmaintained/libzdb/missing-assert.patch
@@ -0,0 +1,13 @@
+diff --git a/test/zdbpp.cpp b/test/zdbpp.cpp
+index 40d2eee..3fde62a 100644
+--- a/test/zdbpp.cpp
++++ b/test/zdbpp.cpp
+@@ -1,6 +1,7 @@
+ #include <iostream>
+ #include <string>
+ #include <map>
++#include <assert.h>
+
+ #include "zdbpp.h"
+ using namespace zdb;
+