aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/apk-file/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/apk-file/APKBUILD b/testing/apk-file/APKBUILD
new file mode 100644
index 0000000000..900fce9c06
--- /dev/null
+++ b/testing/apk-file/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Daniele Debernardi <drebrez@gmail.com>
+# Maintainer: Daniele Debernardi <drebrez@gmail.com>
+pkgname=apk-file
+pkgver=0.3.5
+pkgrel=0
+pkgdesc="Command line front end for pkgs.alpinelinux.org"
+url="https://github.com/genuinetools/apk-file"
+arch="all"
+license="MIT"
+makedepends="go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/genuinetools/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/go/src/github.com/genuinetools/$pkgname"
+
+prepare() {
+ mkdir -p "$srcdir/go/src/github.com/genuinetools"
+ mv "$srcdir/$pkgname-$pkgver" "$builddir"
+}
+
+build() {
+ export GOPATH="$srcdir/go"
+ cd "$builddir"
+ make
+}
+
+check() {
+ export GOPATH="$srcdir/go"
+ cd "$builddir"
+ make test
+}
+
+package() {
+ install -Dm755 "$builddir/apk-file" \
+ "$pkgdir/usr/bin/apk-file"
+}
+
+sha512sums="b007a57a243a7b135663fde76fbad5b97e06dd474a32bfbd5e8ffc6b4f77e76d055b96c65b7001631b70a55816858935dfd7dfbcf016984dd1dc0a6a75939e7f apk-file-0.3.5.tar.gz"