aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/offlineimap/APKBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/community/offlineimap/APKBUILD b/community/offlineimap/APKBUILD
deleted file mode 100644
index 09e785eb5d..0000000000
--- a/community/offlineimap/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
-# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
-pkgname=offlineimap
-pkgver=7.2.4
-pkgrel=0
-pkgdesc="Synchronizes emails between two repositories"
-url="http://www.offlineimap.org"
-arch="noarch"
-license="GPL-2.0-or-later"
-depends="python2 py2-six"
-makedepends="python2-dev asciidoc"
-install=""
-options="!check" # test suite requires credentials for an IMAP and Gmail account
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/OfflineIMAP/${pkgname}/archive/v${pkgver}.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
-
- cd "$builddir"/docs
- make man
-}
-
-package() {
- cd "$builddir"
- python2 setup.py install --root="${pkgdir}" \
- --optimize=1
-
- for man in docs/*.?; do
- install -Dm644 "$man" \
- "$pkgdir"/usr/share/man/man${man##*.}/${man##*/}
- done
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
- install -m644 README.md TODO.rst MAINTAINERS.rst Changelog.md \
- "$pkgdir"/usr/share/doc/$pkgname/
- install -m644 offlineimap.conf* \
- "$pkgdir"/usr/share/doc/$pkgname/examples/
-}
-
-sha512sums="837f822a08f5df59f5332c65b33e0186c215a633c5c17f08790f4c2128a4f6470a75eb02e883dd592b456dbc0ba2b32f670cb716eb602dd8a6bdf12ba2d72cd8 offlineimap-7.2.4.tar.gz"