aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/busybox/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index b68921da3a..e89ad7bf72 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -54,7 +54,7 @@ build() {
-e "s/.*CONFIG_STATIC.*/CONFIG_STATIC=y/" \
"$_config" > .config
# musl does not support GNU regex
- [ "${CTARGET#*musl}" != "$CTARGET" ] && sed -i \
+ [ "$CLIBC" = musl ] && sed -i \
-e "s/CONFIG_EXTRA_COMPAT=y/CONFIG_EXTRA_COMPAT=n/" \
.config
make -C "$_sdir" O="$PWD" silentoldconfig || return 1
@@ -65,7 +65,7 @@ build() {
cd "$_dyndir"
msg "Building dynamic busybox"
cp "$_config" .config
- [ "${CTARGET#*musl}" != "$CTARGET" ] && sed -i \
+ [ "$CLIBC" = musl ] && sed -i \
-e "s/CONFIG_EXTRA_COMPAT=y/CONFIG_EXTRA_COMPAT=n/" \
.config
make -C "$_sdir" O="$PWD" silentoldconfig || return 1