aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/async-profiler/APKBUILD5
-rw-r--r--testing/bfs/APKBUILD1
-rw-r--r--testing/llvm6/APKBUILD1
-rw-r--r--testing/mbuffer/APKBUILD1
-rw-r--r--testing/obfs4proxy/APKBUILD2
5 files changed, 3 insertions, 7 deletions
diff --git a/testing/async-profiler/APKBUILD b/testing/async-profiler/APKBUILD
index e05dbc7a03..985f068447 100644
--- a/testing/async-profiler/APKBUILD
+++ b/testing/async-profiler/APKBUILD
@@ -6,11 +6,10 @@ pkgrel=0
pkgdesc="Sampling CPU and HEAP profiler for Java featuring AsyncGetCallTrace + perf_events"
url="https://github.com/jvm-profiling-tools/async-profiler"
arch="x86 x86_64"
-depends="bash"
license="Apache-2.0"
-options="!checkroot" # due to fakeroot the test suite fails
+depends="bash"
makedepends="linux-headers openjdk8"
-checkdepends="bash openjdk8-dbg"
+checkdepends="openjdk8-dbg"
source="$pkgname-$pkgver.tar.gz::https://github.com/jvm-profiling-tools/async-profiler/archive/v$pkgver.tar.gz
thread-smoke-test_should_do_some_real_work.patch
"
diff --git a/testing/bfs/APKBUILD b/testing/bfs/APKBUILD
index bc16338f18..c0b6e37aed 100644
--- a/testing/bfs/APKBUILD
+++ b/testing/bfs/APKBUILD
@@ -10,7 +10,6 @@ license="0BSD"
makedepends="acl-dev libcap-dev linux-headers attr-dev"
checkdepends="bash acl"
subpackages="$pkgname-doc"
-options="!checkroot"
source="$pkgname-$pkgver.tar.gz::https://github.com/tavianator/bfs/archive/$pkgver.tar.gz
"
diff --git a/testing/llvm6/APKBUILD b/testing/llvm6/APKBUILD
index 0362378cbc..2798d4e260 100644
--- a/testing/llvm6/APKBUILD
+++ b/testing/llvm6/APKBUILD
@@ -23,7 +23,6 @@ source="https://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz
fix-LLVMConfig-cmake-install-prefix.patch
"
builddir="$srcdir/$_pkgname-$pkgver.src"
-options="!checkroot"
# ARMv6 has few failures in test suite that we don't care about currently and
# also it takes forever to run them on the builder.
diff --git a/testing/mbuffer/APKBUILD b/testing/mbuffer/APKBUILD
index 9896fd6a32..7c8830a994 100644
--- a/testing/mbuffer/APKBUILD
+++ b/testing/mbuffer/APKBUILD
@@ -10,7 +10,6 @@ license="GPL-3.0-or-later"
makedepends="linux-headers openssl-dev"
subpackages="$pkgname-doc"
source="http://www.maier-komor.de/software/mbuffer/mbuffer-$pkgver.tgz"
-options="!checkroot"
build() {
./configure \
diff --git a/testing/obfs4proxy/APKBUILD b/testing/obfs4proxy/APKBUILD
index 28d51d2087..64ccef78f8 100644
--- a/testing/obfs4proxy/APKBUILD
+++ b/testing/obfs4proxy/APKBUILD
@@ -8,7 +8,7 @@ url="https://gitweb.torproject.org/pluggable-transports/obfs4.git/"
arch="x86_64 x86 armv7"
license="BSD-3-Clause"
makedepends="go glide"
-options="!strip !net chmod-clean"
+options="!strip chmod-clean"
source="$pkgname-$pkgver.tar.gz::https://github.com/Yawning/obfs4/archive/obfs4proxy-$pkgver.tar.gz
glide.yaml
glide.lock