aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-hurry-filesize/APKBUILD41
-rw-r--r--testing/py3-hurry.filesize/APKBUILD24
2 files changed, 24 insertions, 41 deletions
diff --git a/testing/py-hurry-filesize/APKBUILD b/testing/py-hurry-filesize/APKBUILD
deleted file mode 100644
index 6e3a9d176b..0000000000
--- a/testing/py-hurry-filesize/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-hurry-filesize
-_pkgname=hurry.filesize
-pkgver=0.9
-pkgrel=0
-pkgdesc="A Python library for human readable file sizes"
-url="https://pypi.python.org/pypi/hurry.filesize"
-arch="noarch"
-license="ZPL-2.1"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build || return 1
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
-}
-
-md5sums="8549ccd09bb31b5ff1e8e8c1eacc7794 hurry.filesize-0.9.tar.gz"
-sha256sums="f5368329adbef86accd3bc9490522340bb79260455ae89b1a42c10f63801b9a6 hurry.filesize-0.9.tar.gz"
-sha512sums="24b7ebf5a6e833cec01d1904e5202ab5bde238fbeabb92d893866118e152c0f861f853e11bb71c58d84060bffaf0b7bc88221e37aaacc0b07751febf8a2b1606 hurry.filesize-0.9.tar.gz"
diff --git a/testing/py3-hurry.filesize/APKBUILD b/testing/py3-hurry.filesize/APKBUILD
new file mode 100644
index 0000000000..d7d279b6ca
--- /dev/null
+++ b/testing/py3-hurry.filesize/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-hurry.filesize
+_pkgname=hurry.filesize
+pkgver=0.9
+pkgrel=0
+pkgdesc="A Python library for human readable file sizes"
+url="https://pypi.python.org/pypi/hurry.filesize"
+arch="noarch"
+license="ZPL-2.1"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="24b7ebf5a6e833cec01d1904e5202ab5bde238fbeabb92d893866118e152c0f861f853e11bb71c58d84060bffaf0b7bc88221e37aaacc0b07751febf8a2b1606 hurry.filesize-0.9.tar.gz"