aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/iptables/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index c24900caa6..f5fd4d7708 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -2,11 +2,11 @@
pkgname=iptables
pkgver=1.4.21
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="http://www.netfilter.org/projects/iptables/index.html"
arch="all"
-license=GPL-2
+license="GPL2+"
source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
iptables-1.4.14-musl-fixes.patch
@@ -18,8 +18,9 @@ source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
makedepends="linux-headers autoconf automake"
subpackages="ip6tables $pkgname-doc $pkgname-dev"
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
update_config_sub || return 1
local i
for i in $source; do
@@ -32,7 +33,7 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
export CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure \
--build=$CBUILD \
@@ -52,7 +53,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make -j1 install DESTDIR="$pkgdir" || return 1
rm "$pkgdir"/usr/lib/*.la || return 1