aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/redis/redis-unbundle-jemalloc.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/redis/redis-unbundle-jemalloc.patch b/testing/redis/redis-unbundle-jemalloc.patch
new file mode 100644
index 0000000000..9213f5d635
--- /dev/null
+++ b/testing/redis/redis-unbundle-jemalloc.patch
@@ -0,0 +1,14 @@
+--- src/redis-2.6.16/src/Makefile
++++ src/redis-2.6.16/src/Makefile.new
+@@ -71,9 +71,8 @@
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)