aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pyache/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-pyache/APKBUILD b/testing/py3-pyache/APKBUILD
new file mode 100644
index 0000000000..e74ebf3a11
--- /dev/null
+++ b/testing/py3-pyache/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-pyache
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Python numpy caching library"
+url="https://github.com/MycroftAI/pyache"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-numpy"
+makedepends="py3-setuptools py3-numpy-dev"
+source="https://pypi.python.org/packages/source/p/pyache/pyache-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/pyache-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0ae228ccfd270991ea7c4d074425580f45b0bc008a9e577fd0bd897bd2f64f40df7fe4c52e584dfdae7fd6b9604330400553445a7e2611d308bb96d13d4e8d84 pyache-0.1.0.tar.gz"