aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-trio/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/testing/py3-trio/APKBUILD b/testing/py3-trio/APKBUILD
index befcbea267..0ce4092fbe 100644
--- a/testing/py3-trio/APKBUILD
+++ b/testing/py3-trio/APKBUILD
@@ -1,24 +1,29 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-trio
-pkgver=0.13.0
+pkgver=0.14.0
pkgrel=0
pkgdesc="A friendly Python library for async concurrency and I/O"
url="https://trio.readthedocs.io/"
arch="noarch"
license="MIT OR Apache-2.0"
-depends="python3 py3-sniffio py3-outcome py3-idna py3-sortedcontainers"
+depends="python3 py3-sniffio py3-outcome py3-idna py3-sortedcontainers py3-openssl"
makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-astor py3-trustme"
source="https://pypi.python.org/packages/source/t/trio/trio-$pkgver.tar.gz"
-options="!check" # Requires macOS specific library
+options="!check" # Test fail https://github.com/python-trio/trio/issues/1499
builddir="$srcdir/trio-$pkgver"
build() {
python3 setup.py build
}
+check() {
+ pytest -m "not redistributors_should_skip"
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="022e7923a68905400a0095a39b10c0216041e92bfbb2b7437140f212c1184a99e1e9a20196e1762ceb48236d5c67448f67ce476cd1dd07a1a526e712c54d5bd9 trio-0.13.0.tar.gz"
+sha512sums="11653720f8152f296186599eeb522df4c39b6c19c028f29af0d73524ab8cb59d03d5966e73cd942cdea31cc273c3b686980c508c39421427089f43157c8c1f3e trio-0.14.0.tar.gz"