aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/omxplayer/APKBUILD6
-rw-r--r--main/omxplayer/fix-dbus-dispatch.patch13
2 files changed, 18 insertions, 1 deletions
diff --git a/main/omxplayer/APKBUILD b/main/omxplayer/APKBUILD
index 8c77b9053b..42c53e6b03 100644
--- a/main/omxplayer/APKBUILD
+++ b/main/omxplayer/APKBUILD
@@ -2,7 +2,7 @@
pkgname=omxplayer
pkgver=0.20151205
_commitid=f5440845cdd91e7816de1937c30057f58c10c268
-pkgrel=0
+pkgrel=1
pkgdesc="Commandline OMX player for Raspberry Pi"
url="https://github.com/popcornmix/omxplayer"
arch="armhf"
@@ -16,6 +16,7 @@ source="omxplayer-$pkgver.tar.gz::https://github.com/popcornmix/omxplayer/archiv
issue-260.patch
issue-297.patch
fix-makefile.patch
+ fix-dbus-dispatch.patch
default-font.patch
omxplayer-alsa.patch
@@ -62,6 +63,7 @@ md5sums="7afc357b183d3c3b5b8e17cdec0e50fd omxplayer-0.20151205.tar.gz
a900cdded87b7df503c6599ac43bd8de issue-260.patch
c858882036b9fb03859edf7ce4a1d942 issue-297.patch
d8f335e1dff4b34faf36c25ad2c2b881 fix-makefile.patch
+f56949213d53b8fbd6c0b0e393b9cab0 fix-dbus-dispatch.patch
9ebd96155288809fe0a657cf491e433f default-font.patch
628a9bc0b26f75547299e92542e65d47 omxplayer-alsa.patch
b4054a311d76aef91aa10bacd68bc9c4 omxplayer.initd
@@ -70,6 +72,7 @@ sha256sums="de129817e5fda01f49e0fd80727caa14f2a715f7af9f035d77b1d0e9d0dc57d2 om
5eb797de354c63a23847a574b103a28d451a4329320f3335f82dc000adbc5c63 issue-260.patch
389c97df4919a3fe4d115f092cb256246e33374150102f0e2cb9ce11456cadb1 issue-297.patch
799b0aba6aef8c665a685777cd912268315309d0d74ce76be5fdfd0dcffbb422 fix-makefile.patch
+2de5b9b51146508ecff219d2c02a7df1c4ba4814b978254b2610d06eb4f6a0a8 fix-dbus-dispatch.patch
2bab3d05b12d730737220b8c0052498a34bbebc12b7beb8afb3c054beb0fb3bb default-font.patch
87dc80b61ce6c69a52637dffb64f526e7fa213e4c2b0c97177457c95851ec594 omxplayer-alsa.patch
e2db0f7ffbe2488dd69ee0bfad006bd863f418554f078ca3432f643de7589d2f omxplayer.initd
@@ -78,6 +81,7 @@ sha512sums="2993319f710b107d7ce431ec92868b0ba48a6209d06fa978b2d609cfe267abe432db
c349eea5f7c513a07d82a6cf6467c4d21bcb29c053bc5e39d8f675b1212db9beef0abf5248d50ac5a2f14fda73055786f94f421377ffcf5f6bcf8daa2f1b56e8 issue-260.patch
2a8a6def1e09f726cba58c0b9109fa6c4fbd4a3b4f1d27d200488f262a0e0978579d83db7fe24f1d3e03beef318c3674ed79cbd2f1994c4551a59c9fe0f63489 issue-297.patch
3210242f9b834ffec9d3077d5a25caf8be84aa7f4f13c73eb7f61c0a406ec787e4055951fc5a6236f1da7897c95db94a5e11e25d1b3e859a6ea67f31fc6eb517 fix-makefile.patch
+fe7d3ff020513a1688333918665468fffefd5b1e94bbc7cac82823e625e64c7894c438a30361deedf7b5545a38bcac2aced7d8ce0ab6bc5ef4d79eba5fa5fa40 fix-dbus-dispatch.patch
8aa58aaa07453186302dc68d92f28c1b50bf0f8fccd50359640a7fc8339b233b32a0c8c02284a9974599e56d69cc557acc25e76e6438c6d64d15afd9c1788a8e default-font.patch
bc11327631453026784a7b80efb259f6f86a670a12dfc3ba8b92b841611db73408ffab89b9c131bc7ff59695a5eef6f3e94af19136ffcfcbac9a9a7362a93f5f omxplayer-alsa.patch
3ddd32235d87a46478d0237ee9b253edeb75729e377b09a33069ecdca2ee230d2851f308897ee75ff69a9f3bdd2876f490bc1667a572dce1c186f80fddcf6df3 omxplayer.initd
diff --git a/main/omxplayer/fix-dbus-dispatch.patch b/main/omxplayer/fix-dbus-dispatch.patch
new file mode 100644
index 0000000000..ef732c5094
--- /dev/null
+++ b/main/omxplayer/fix-dbus-dispatch.patch
@@ -0,0 +1,13 @@
+diff --git a/OMXControl.cpp b/OMXControl.cpp
+index 0ef8e5f..834461f 100644
+--- a/OMXControl.cpp
++++ b/OMXControl.cpp
+@@ -88,7 +88,7 @@ int OMXControl::init(OMXClock *m_av_clock, OMXPlayerAudio *m_player_audio, OMXPl
+ void OMXControl::dispatch()
+ {
+ if (bus)
+- dbus_connection_read_write_dispatch(bus, 0);
++ dbus_connection_read_write(bus, 0);
+ }
+
+ int OMXControl::dbus_connect(std::string& dbus_name)