aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libglacierapp/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/libglacierapp/APKBUILD b/testing/libglacierapp/APKBUILD
new file mode 100644
index 0000000000..4b371dbcfe
--- /dev/null
+++ b/testing/libglacierapp/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libglacierapp
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="libglacierapp"
+url="https://github.com/nemomobile-ux/libglacierapp"
+arch="all"
+license="LGPL-2.0-or-later"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev"
+source="https://github.com/nemomobile-ux/libglacierapp/archive/$pkgver/libglacierapp-$pkgver.tar.gz"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+
+sha512sums="ffa9fe41c2bc9ef875226cd94b18b3a206a5c73bb4db0b259a6abae67601cb5e2853e8cfa3bfc936fe488ca37459d3f5c39928d8188de761fd7889c5093052d0 libglacierapp-0.4.0.tar.gz"