aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/upx/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/upx/APKBUILD b/community/upx/APKBUILD
index 7d1eadfaee..4efb526304 100644
--- a/community/upx/APKBUILD
+++ b/community/upx/APKBUILD
@@ -5,15 +5,13 @@ pkgver=3.96
pkgrel=0
pkgdesc="The Ultimate Packer for eXecutables"
url="https://upx.github.io"
-arch="all !aarch64 !armhf !armv7" # Failure to build
+arch="all !s390x !aarch64 !armhf !armv7" # Failure to build/run
license="GPL-2.0 Public-Domain"
# perl-dev is used to generate man pages
makedepends="bash perl-dev ucl-dev zlib-dev"
subpackages="$pkgname-doc"
source="https://github.com/upx/upx/releases/download/v$pkgver/upx-$pkgver-src.tar.xz
0001-rm-broken-whitespace-check.patch"
-# tests fail
-if [ "$CARCH" = "s390x" ]; then options="!check"; fi
builddir="$srcdir/$pkgname-$pkgver-src"
build() {
@@ -31,12 +29,17 @@ check() {
cp -f /bin/busybox ./sh
for i in "-1" "-d"; do
- $upx $i -qf sh &>/dev/null
+ $upx $i -qf sh >/dev/null
out="$(./sh -c 'echo works')"
test "x$out" = "xworks"
done
rm -f sh
+ # FIXME: fix broken architectures
+ case "$CARCH" in
+ x86) return 0;;
+ esac
+
# then check less common statically-linked binaries (PIE and non-PIE)
for v in "-static"; do # FIXME: fix "-static -no-pie"
echo "checking $v..."
@@ -53,9 +56,11 @@ check() {
return 0;
}
EOF
+ cp upxtest upxtest.orig
for i in "-1" "-d"; do
- $upx $i -qf upxtest &>/dev/null
+ echo "$upx $i -qf upxtest"
+ $upx $i -qf upxtest >/dev/null
out=$(./upxtest "")
test "x$out" = "x2,0x1000200030004002"
done