aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/jack/APKBUILD8
-rw-r--r--main/jack/fix-execinfo.patch32
2 files changed, 26 insertions, 14 deletions
diff --git a/main/jack/APKBUILD b/main/jack/APKBUILD
index 49e4d58141..38065d867c 100644
--- a/main/jack/APKBUILD
+++ b/main/jack/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jack
pkgver=1.9.10
-pkgrel=0
+pkgrel=1
pkgdesc="The Jack Audio Connection Kit"
url="http://www.jackaudio.org"
arch="all"
@@ -62,8 +62,8 @@ _clients() {
}
md5sums="4aeb91d7ae0cabce98355436ed4f217a jack-1.9.10.tar.bz2
-0116cfe01bc72bc945235ed0b858dfdc fix-execinfo.patch"
+66a37f3313c8268291910db19e637389 fix-execinfo.patch"
sha256sums="5bc6336e6ac9799e3cb241915e2ba5d01b030589bbb2afae39579a59ef0f2f56 jack-1.9.10.tar.bz2
-f30920899259fc3b4357deba42291cce5dfa7777d96d12eb85a9541c7c0ebffd fix-execinfo.patch"
+0fd5deada71ebd772e8a25032a5258b8686a4394ae9c4066377bb9531031afb0 fix-execinfo.patch"
sha512sums="d64d233c2d626a4ae635f009a7209c2c8740c7959988d282e733b5fc663c168301a2aa2b517dff80f44cb25417aeb5ccca87da5c24616dadf38d69a6cb307e7c jack-1.9.10.tar.bz2
-99b89146e534b76bf750c13b522dea070c0f6917afb5d2c81e5a4f4f08a66109232b1d7e7b73b52f4772306719f95434b8af6ab6be4ae780103f874c6dbde017 fix-execinfo.patch"
+b5abec7e67485d1c13f399b5961539177dd35d21c5dd95e0aa767adb0f5b1e588e9ca2f9b29cc4d66fc039311ff7eacc4cf21f6700ef0a2c8de99b63cb00f84d fix-execinfo.patch"
diff --git a/main/jack/fix-execinfo.patch b/main/jack/fix-execinfo.patch
index 170c432774..24218aebfd 100644
--- a/main/jack/fix-execinfo.patch
+++ b/main/jack/fix-execinfo.patch
@@ -1,12 +1,24 @@
---- jack-1.9.9.5.orig/dbus/sigsegv.c
-+++ jack-1.9.9.5/dbus/sigsegv.c
-@@ -27,7 +27,9 @@
- #include <stdio.h>
- #include <signal.h>
- #include <dlfcn.h>
+--- jack-1.9.10.orig/dbus/sigsegv.c
++++ jack-1.9.10/dbus/sigsegv.c
+@@ -11,6 +11,8 @@
+ * Copyright (C) 2005 - 2008 Jaco Kroon
+ */
+
+#ifdef __GLIBC__
- #include <execinfo.h>
++
+ #if defined(HAVE_CONFIG_H)
+ #include "config.h"
+ #endif
+@@ -209,4 +211,12 @@
+ static void __attribute((constructor)) init(void) {
+ setup_sigsegv();
+ }
+#endif
- #include <errno.h>
- #ifndef NO_CPP_DEMANGLE
- char * __cxa_demangle(const char * __mangled_name, char * __output_buffer, size_t * __length, int * __status);
++
++#else
++
++int setup_sigsegv() {
++ return 1;
++}
++
+ #endif