aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/iwd/APKBUILD16
-rw-r--r--community/iwd/disable-eapol-test.patch30
-rw-r--r--community/iwd/fix-scan.patch33
-rw-r--r--community/iwd/iwd.post-upgrade6
-rw-r--r--community/iwd/main.conf167
5 files changed, 31 insertions, 221 deletions
diff --git a/community/iwd/APKBUILD b/community/iwd/APKBUILD
index 54149e2856..64c8795c12 100644
--- a/community/iwd/APKBUILD
+++ b/community/iwd/APKBUILD
@@ -1,23 +1,22 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=iwd
-pkgver=1.2
-pkgrel=1
+pkgver=1.4
+pkgrel=0
pkgdesc="Internet Wireless Daemon"
url="https://iwd.wiki.kernel.org/"
arch="all"
license="LGPL-2.1-or-later"
-depends="ell>=0.26"
+depends="ell>=0.27"
makedepends="ell-dev dbus-dev readline-dev linux-headers asciidoc"
checkdepends="coreutils"
subpackages="$pkgname-doc $pkgname-openrc"
source="https://mirrors.edge.kernel.org/pub/linux/network/wireless/iwd-$pkgver.tar.gz
dbus-netdev-group.patch
- disable-eapol-test.patch
fix-rawmemchr.patch
- fix-scan.patch
iwd.initd
main.conf
+ iwd.post-upgrade
"
build() {
./configure \
@@ -48,10 +47,9 @@ package() {
"$pkgdir"/etc/$pkgname/main.conf
}
-sha512sums="2ff3c03dc0abc031d4149eb48736ddf1cf85681ba3b8e47d3bbfa89ff4772887b682c5fd449060601f7eddf790d6637528f63e8edd53cf8b5f9be37ddcdd22e3 iwd-1.2.tar.gz
+sha512sums="0e4f61c994080f5bbc1528edf76bb16f318e1ebb3beeb5c5c29c991ebdcf12f0e4484f7b601d355443d8b41ed86cc5a9fbd16aace01c526aebb2d78b75b8b214 iwd-1.4.tar.gz
7d3bc26b558ebfd22335b946f09abd5326e885275979c617af7def1468ade23ba7605f3b13aaf91836035c130aaec04be0ff2708a898f3ae835e0eef4e78fa0e dbus-netdev-group.patch
-b3dfb5a2de110a8d6218fc6ec7f8e7690bc2ad130037051867d105aff23031d2340f55ac99f060d97856cb5818df24eb7631dc82dcbc196aa44251b2e5edcf7b disable-eapol-test.patch
2d8cc70a9475465755f8187c6afb93e5792842dccf55f977ce111e98477517feae1be81eefd50c53149c61d7944a728dc504938ad678a2c789703bcc6f1e7507 fix-rawmemchr.patch
-f3a101605e2823eda0ee41945cecd15d1c2b2cf44315e336e079db283f6f8ed4b76c7192cab7ad6f1ade9c361dd54c6866b2f3c3cec7e26ea89b5c0a29f7365c fix-scan.patch
1a913fa19a76a18d92b8f44cb5b4b99a64b4e2f7d2b4a486bf1ba2f939aea7dcca772fca91483011ada58aaa3addc29c76ececd708b2187e57f72aa040ac77e6 iwd.initd
-cc875faa69d5a0a673f923b6373a0d25e15166eef11b91d2ed75e99099e2087ba3d7930243b53cb6c53fc25bfe5f536268da7d40c7b286170388e813ce73d949 main.conf"
+09f4097e653cfecfa1e4bc7b4843832785d0a8ef2a8ecf7daa3d5be704d9ac311fbbecf9f9f5b8b1c75beff894e4cf0d8fda4d6ff728a638dedf77aff0197179 main.conf
+414cb08e01735a66dfb57eac7f308ce75f8f7adf679c5e38418293a0acb2398f9b4df4dd50a6756e48eb03b86de1546e2f852a28677842f2c453a0db86d49f71 iwd.post-upgrade"
diff --git a/community/iwd/disable-eapol-test.patch b/community/iwd/disable-eapol-test.patch
deleted file mode 100644
index 41b8d65d4e..0000000000
--- a/community/iwd/disable-eapol-test.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/Makefile.in 2019-08-28 21:45:47.000000000 +0200
-+++ b/Makefile.in 2019-08-29 00:48:01.030221354 +0200
-@@ -209,7 +209,7 @@
- am__EXEEXT_8 = unit/test-cmac-aes$(EXEEXT) unit/test-hmac-md5$(EXEEXT) \
- unit/test-hmac-sha1$(EXEEXT) unit/test-hmac-sha256$(EXEEXT) \
- unit/test-prf-sha1$(EXEEXT) unit/test-kdf-sha256$(EXEEXT) \
-- unit/test-crypto$(EXEEXT) unit/test-eapol$(EXEEXT) \
-+ unit/test-crypto$(EXEEXT) \
- unit/test-mpdu$(EXEEXT) unit/test-ie$(EXEEXT) \
- unit/test-util$(EXEEXT) unit/test-ssid-security$(EXEEXT) \
- unit/test-arc4$(EXEEXT) unit/test-wsc$(EXEEXT) \
-@@ -1148,7 +1148,7 @@
- @TOOLS_TRUE@tools_test_runner_LDADD = $(ell_ldadd)
- unit_tests = unit/test-cmac-aes unit/test-hmac-md5 unit/test-hmac-sha1 \
- unit/test-hmac-sha256 unit/test-prf-sha1 unit/test-kdf-sha256 \
-- unit/test-crypto unit/test-eapol unit/test-mpdu unit/test-ie \
-+ unit/test-crypto unit/test-mpdu unit/test-ie \
- unit/test-util unit/test-ssid-security unit/test-arc4 \
- unit/test-wsc unit/test-eap-mschapv2 unit/test-eap-sim \
- unit/test-sae unit/test-p2p $(am__append_20)
-@@ -1205,8 +1205,7 @@
- src/ie.h src/ie.c
-
- unit_test_mpdu_LDADD = $(ell_ldadd)
--unit_test_eapol_SOURCES = unit/test-eapol.c \
-- src/crypto.h src/crypto.c \
-+unit_test_eapol_SOURCES = src/crypto.h src/crypto.c \
- src/ie.h src/ie.c \
- src/watchlist.h src/watchlist.c \
- src/eapol.h src/eapol.c \
diff --git a/community/iwd/fix-scan.patch b/community/iwd/fix-scan.patch
deleted file mode 100644
index 42fdf1db79..0000000000
--- a/community/iwd/fix-scan.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From d2556a48b7d65eb670fb0ce20e3f929bf9839a20 Mon Sep 17 00:00:00 2001
-From: Denis Kenzior <denkenz@gmail.com>
-Date: Mon, 2 Dec 2019 10:53:55 -0600
-Subject: scan: Fix crash when scan is triggered outside iwd
-
- #0 0x000055555558ee5d in scan_notify (msg=0x55555560b640, user_data=0x0) at src/scan.c:1706
- #1 0x00007ffff7f2c78c in ?? () from /usr/lib/libell.so.0
- #2 0x00007ffff7f299ec in ?? () from /usr/lib/libell.so.0
- #3 0x00007ffff7f28e4a in l_main_iterate () from /usr/lib/libell.so.0
- #4 0x00007ffff7f28efc in l_main_run () from /usr/lib/libell.so.0
- #5 0x00007ffff7f290b9 in l_main_run_with_signal () from /usr/lib/libell.so.0
- #6 0x00005555555639c4 in main (argc=1, argv=0x7fffffffec18) at src/main.c:497
----
- src/scan.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/scan.c b/src/scan.c
-index e8133ff0..97b37c68 100644
---- a/src/scan.c
-+++ b/src/scan.c
-@@ -1703,7 +1703,8 @@ static void scan_notify(struct l_genl_msg *msg, void *user_data)
- else
- sc->state = SCAN_STATE_PASSIVE;
-
-- sr->start_time_tsf = start_time_tsf;
-+ if (sr)
-+ sr->start_time_tsf = start_time_tsf;
-
- break;
-
---
-cgit 1.2-0.3.lf.el7
-
diff --git a/community/iwd/iwd.post-upgrade b/community/iwd/iwd.post-upgrade
new file mode 100644
index 0000000000..ec087304ac
--- /dev/null
+++ b/community/iwd/iwd.post-upgrade
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ -f /etc/iwd/main.conf ]; then
+ sed -i -e s/enable_network_config=True/EnableNetworkConfiguration=True/ /etc/iwd/main.conf
+ sed -i -e s/resolve_method=resolvconf/NameResolvingService=resolvconf/ /etc/iwd/main.conf
+fi
diff --git a/community/iwd/main.conf b/community/iwd/main.conf
index f53990339d..8019ea1f20 100644
--- a/community/iwd/main.conf
+++ b/community/iwd/main.conf
@@ -2,166 +2,35 @@
# configuration options below, remove # from the beginning of a respective line.
# this file is not distributed upstream as of iwd 1.0 version
-# It is picked from last version in which is distributed
+# It is created as transitional config from latest version
# Please read iwd.config(5), iwd.network(5), iwctl(1), iwmon(1) before setting
# these parameters below
-[EAP]
-mtu=1400
+# main.conf format is changed with iwd 1.3 release
-[EAPoL]
-max_4way_handshake_time=5
+#[EAP]
+#mtu=1400
-[General]
+#[EAPoL]
+#max_4way_handshake_time=5
-#
-# Enable network configuration. Setting this option to 'True' enables iwd to
-# configure the network interfaces with the IP addresses. There are two types
-# IP addressing supported by iwd: static and dynamic. The static IP addresses
-# are configured through the network configuration files located in
-# '/var/lib/iwd/' directory. For more information on the static configuration
-# options refer to the wiki page (https://iwd.wiki.kernel.org/ipconfiguration).
-# If no static IP configuration has been provided for a network, iwd will
-# attempt to obtain the dynamic addresses from the network through the built-in
-# DHCP client.
-#
-# The network configuration feature is disabled by default.
-#
-# enable_network_config=False
+#[General]
-#
-# Indicate a DNS resolution method used by the system. This configuration option
-# must be used in conjunction with 'enable_network_config'. The currently
-# supported methods include: systemd-resolved and the resolv.conf based options
-# (such as openresolv, etc).
-# The following configuration 'dns_resolve_method' options are supported:
-# systemd
-# resolvconf
-#
-# If not specified, 'systemd' is used as default.
-#
-# dns_resolve_method=resolvconf
-#
+#EnableNetworkConfiguration=True
+#ControlPortOverNL80211=True
+#RoamThreshold=-70
-#
-# Enable/Disable sending EAPoL packets over NL80211. Enabled by default if
-# kernel support is available. Doing so sends all EAPoL traffic over directly
-# to the supplicant process (iwd) instead of putting these on the Ethernet
-# device. Since only the supplicant can usually make sense / decrypt these
-# packets, enabling this option can save some CPU cycles on your system and
-# avoids certain long-standing race conditions.
-#
-# Note, iwmon cannot currently spy on unicast packets sent over netlink, so
-# if you need to capture EAPoL packets (e.g. for debugging) then this option
-# should be set to False.
-control_port_over_nl80211=True
-#
-# Set the threshold RSSI for roaming (default -70)
-roam_rssi_threshold=-70
-#
-# Do not allow iwd to destroy / recreate wireless interfaces at startup,
-# including default interfaces. Enable this behavior if your wireless card
-# driver is buggy or does not allow such an operation, or if you do not want
-# iwd to manage netdevs for another reason. For most users with an upstream
-# driver it should be safe to omit/disable this setting.
-# use_default_interface=true
+#[Network]
-#
-# Explicitly enforce/disable management frame protection
-#
-# 0 - Disable management frame protection
-# 1 - Set management frame protection capable (default)
-# 2 - Management frame protection required
-#
-# management_frame_protection=1
+#NameResolvingService=resolvconf
-#
-# Enable/disable ANQP queries. The way IWD does ANQP queries is dependent on
-# a recent kernel patch (available in Kernel 5.3). If your kernel does not have
-# this functionality this should be disabled (default). Some drivers also do a
-# terrible job of sending public action frames (freezing or crashes) which is
-# another reason why this has been turned off by default. All aside, if you want
-# to connect to Hotspot 2.0 networks ANQP is most likely going to be required
-# (you may be able to pre-provision to avoid ANQP).
-#
-# disable_anqp=true
+#[Scan]
-#
-# Control the behavior of MAC address randomization by setting the
-# mac_randomize option. iwd supports the following options:
-# "default" - Lets the kernel assign a mac address from the permanent mac
-# address store when the interface is created by iwd. Alternatively,
-# if the 'use_default_interface' is set to true, then the mac address is
-# not touched.
-# "once" - MAC address is randomized once when iwd starts. If
-# 'use_default_interface' is set to true, only the interface(s) managed
-# by iwd will be randomized.
-#
-# One can control which part of the address is randomized using
-# mac_randomize_bytes option. iwd supports the following options:
-# "nic" - Randomize only the NIC specific octets (last 3 octets). Note that
-# the randomization range is limited to 00:00:01 to 00:00:FE. The permanent
-# mac address of the card is used for the initial 3 octets.
-# "full" - Randomize the full 6 octets. The locally-administered bit will
-# be set.
-#
-# mac_randomize=default
-# mac_randomize_bytes=full
+# DisablePeriodicScan=false
+# DisableRoamingScan=false
-[Scan]
-#
-# Disable periodic scan. Setting this option to 'true' will prevent iwd from
-# issuing the periodic scans for the available networks while disconnected.
-# The behavior of the user-initiated scans isn't affected.
-# The periodic scan is enabled by default.
-#
-# disable_periodic_scan=false
-#
+#[Blacklist]
-#
-# Disable roaming scan. Setting this option to 'true' will prevent iwd from
-# issuing the roaming scans for the available networks while connected.
-# The behavior of the user-initiated scans isn't affected.
-# The roaming scan is enabled by default.
-#
-# disable_roaming_scan=false
-#
+#[Rank]
-#
-# Disable MAC address randomization. Setting this option to 'true' will prevent
-# the capable network adapters from randomizing MAC addresses during the active
-# scans for networks, thus decreasing user privacy.
-# The MAC address randomization is enabled by default.
-#
-# disable_mac_address_randomization=false
-#
-
-[Blacklist]
-#
-# Configure BSS blacklist time/multipler/max. If a connection to a BSS fails for
-# whatever reason we can avoid connecting to this BSS in the future by
-# blacklisting it. These three options configure how long a BSS is blacklisted
-# for.
-#
-# bss_blacklist_time - The initial timeout for a blacklisted BSS in
-# seconds (default 60)
-# bss_blacklist_multiplier - What bss_blacklist_time is multiplied by after
-# future unsuccessful connection attempts in
-# seconds (default 30)
-# bss_blacklist_max_time - The maximum time a BSS can be blacklisted for in
-# seconds (default 86400)
-#
-# bss_blacklist_time=60
-# bss_blacklist_multiplier=30
-# bss_blacklist_max_time=86400
-
-[Rank]
-#
-# Manually specify a 5G ranking factor. 5G networks are already preferred but
-# only in terms of calculated data rate, which is RSSI dependent. This means it
-# is still possible for IWD to prefer a 2.4GHz AP in the right conditions.
-# This ranking provides a way to further weight the ranking towards 5G if
-# required. Also, a lower 5G factor could be used to weight 2.4GHz if that is
-# desired. The default is 1.0, which does not affect the calculated ranking.
-#
-# rank_5g_factor=1.0
+# BandModifier5Ghz=1.0