aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-us/APKBUILD (renamed from testing/py-us/APKBUILD)12
-rw-r--r--testing/py3-us/fix-requires.patch (renamed from testing/py-us/fix-requires.patch)0
2 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-us/APKBUILD b/testing/py3-us/APKBUILD
index 11d275e63b..7f11b577c0 100644
--- a/testing/py-us/APKBUILD
+++ b/testing/py3-us/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-us
+pkgname=py3-us
_pkgname=us
pkgver=1.0.0
pkgrel=0
@@ -8,9 +8,11 @@ pkgdesc="A Python US state meta information module"
url="https://github.com/sunlightlabs/python-us"
arch="noarch"
license="BSD"
-depends="python2"
+replaces="py-us" # for backwards compatibility
+provides="py-us=$pkgver-r$pkgrel" # for backwards compatibility
+depends="py3-jellyfish py3-setuptools python3"
depends_dev=""
-makedepends="python2-dev py-setuptools"
+makedepends="py3-setuptools python3-dev"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
@@ -29,12 +31,12 @@ prepare() {
build() {
cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
sha512sums="942e3b5af01e5ecab58fbc84905976ce57085e766bde00cc08f02586d7387069270a8927d6f6dbfcba324f290046763efe3d64c7568667dcf86f080048960a25 us-1.0.0.tar.gz
diff --git a/testing/py-us/fix-requires.patch b/testing/py3-us/fix-requires.patch
index ac42c6dc2c..ac42c6dc2c 100644
--- a/testing/py-us/fix-requires.patch
+++ b/testing/py3-us/fix-requires.patch