aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/waylandpp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/waylandpp/APKBUILD b/testing/waylandpp/APKBUILD
new file mode 100644
index 0000000000..bef5a5e740
--- /dev/null
+++ b/testing/waylandpp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=waylandpp
+pkgver=0.2.5
+pkgrel=0
+arch="all"
+url="https://github.com/NilsBrause/waylandpp"
+pkgdesc="Wayland C++ bindings"
+license="MIT AND GPL-3.0-or-later"
+depends_dev="pugixml-dev wayland-dev mesa-dev"
+makedepends="$depends_dev cmake doxygen graphviz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nilsbrause/$pkgname/archive/$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="a8c80282022b2ede3c3d0f5516e236aedaf3ef685565da8c61214fe37eda139bf152093eb29960be1889798eef5631b9d68a5e832c10cf1160c4a90f45eccb6e waylandpp-0.2.5.tar.gz"