aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/dnsmasq/APKBUILD4
-rw-r--r--main/dnsmasq/dnsmasq.initd6
2 files changed, 7 insertions, 3 deletions
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index ec7d0b51b1..9a2c486649 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -15,7 +15,7 @@
#
pkgname=dnsmasq
pkgver=2.79
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight DNS, DHCP, RA, TFTP and PXE server"
url="http://www.thekelleys.org.uk/dnsmasq/"
arch="all"
@@ -74,6 +74,6 @@ dnssec() {
}
sha512sums="c808abc8f24f302cac3609a78fa5a402019a397a248156cda9ce60e6cd706b9f689772af5301c8d1475c3cbbe39ea1528c1e1406f9ec0b7e8153a0899be02352 dnsmasq-2.79.tar.gz
-fe6155ff79f06d1813b5c65eb00c69ed41749882ce9f8458da95797c8d870b635aa1df04335cdab068018432c74b87e2166096fcf60597f1c4594279f31c38e6 dnsmasq.initd
+296c58359f2deb9f7a48fa8d12205e07fd977b322f489a7a6a4f1a36f16d8fcf527593daeb80ae304e8acc4e075c491a1dbfca42dd46e0137f400a47a11ef2d7 dnsmasq.initd
9a401bfc408bf1638645c61b8ca734bea0a09ef79fb36648ec7ef21666257234254bbe6c73c82cc23aa1779ddcdda0e6baa2c041866f16dfb9c4e0ba9133eab8 dnsmasq.confd
d01077f39e1240041a6700137810f254daf683b2d58dafecb6b162e94d694992e57d45964a57993b298f97c2b589eedcf9fb1506692730a38b7f06b5f55ba8d8 uncomment-conf-dir.patch"
diff --git a/main/dnsmasq/dnsmasq.initd b/main/dnsmasq/dnsmasq.initd
index a16c206a8f..4fc45136b8 100644
--- a/main/dnsmasq/dnsmasq.initd
+++ b/main/dnsmasq/dnsmasq.initd
@@ -25,6 +25,7 @@ if [ "${RC_SVCNAME#*.}" != "$RC_SVCNAME" ]; then
: ${BRIDGE_DHCP_RANGE:="10.0.3.2,10.0.3.254"}
: ${BRIDGE_DHCP_MAX:="253"}
: ${BRIDGE_MAC:="00:16:3e:00:00:00" }
+ : ${DNSMASQ_LISTEN_BRIDGE_ADDR:=yes}
fi
.
@@ -86,7 +87,10 @@ start_pre() {
if [ -z "$DISABLE_IPTABLES" ]; then
setup_firewall -I -A
fi
- command_args="$command_args --strict-order --bind-interfaces --listen-address ${BRIDGE_ADDR} --except-interface=lo --interface=$BRIDGE --dhcp-range $BRIDGE_DHCP_RANGE --dhcp-lease-max=$BRIDGE_DHCP_MAX --dhcp-no-override --dhcp-leasefile=$leasefile --dhcp-authoritative"
+ if yesno "$DNSMASQ_LISTEN_BRIDGE_ADDR"; then
+ command_args="$command_args --listen-address ${BRIDGE_ADDR}"
+ fi
+ command_args="$command_args --strict-order --bind-interfaces --except-interface=lo --interface=$BRIDGE --dhcp-range $BRIDGE_DHCP_RANGE --dhcp-lease-max=$BRIDGE_DHCP_MAX --dhcp-no-override --dhcp-leasefile=$leasefile --dhcp-authoritative"
}
stop_post() {