aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/watchman/APKBUILD9
-rw-r--r--testing/watchman/e77eb9597c4c094a0b0bbeef0b957b49b40b87eb.patch48
2 files changed, 54 insertions, 3 deletions
diff --git a/testing/watchman/APKBUILD b/testing/watchman/APKBUILD
index a1fe5a53f3..14b46f88ea 100644
--- a/testing/watchman/APKBUILD
+++ b/testing/watchman/APKBUILD
@@ -1,13 +1,15 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=watchman
pkgver=4.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="A file watching service"
url="https://facebook.github.io/watchman/"
arch="all"
license="Apache-2.0"
makedepends="pcre-dev autoconf automake linux-headers libtool libressl-dev python3-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/watchman/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/watchman/archive/v$pkgver.tar.gz
+ e77eb9597c4c094a0b0bbeef0b957b49b40b87eb.patch
+ "
builddir="$srcdir/"$pkgname-$pkgver
build() {
@@ -27,4 +29,5 @@ package() {
make DESTDIR=$pkgdir install-binPROGRAMS
}
-sha512sums="f25b77f73bca3e25a0254a98af5c8125b8a31133ec3702cac656459f3522d5f0bf2e96d5893ca9fb5ce3ae18adce58224746bd8ca9afc5c312bcd697cb5b2d5d watchman-4.9.0.tar.gz"
+sha512sums="f25b77f73bca3e25a0254a98af5c8125b8a31133ec3702cac656459f3522d5f0bf2e96d5893ca9fb5ce3ae18adce58224746bd8ca9afc5c312bcd697cb5b2d5d watchman-4.9.0.tar.gz
+6bb0bb780c6f4067e74dcdeafdef3063ac8e1885e7e9529594e83261107975b152b4fde2693d026c275a7dc7b7dc08e209dd772aeea186678933dbbec5a8f1fe e77eb9597c4c094a0b0bbeef0b957b49b40b87eb.patch"
diff --git a/testing/watchman/e77eb9597c4c094a0b0bbeef0b957b49b40b87eb.patch b/testing/watchman/e77eb9597c4c094a0b0bbeef0b957b49b40b87eb.patch
new file mode 100644
index 0000000000..17288fef58
--- /dev/null
+++ b/testing/watchman/e77eb9597c4c094a0b0bbeef0b957b49b40b87eb.patch
@@ -0,0 +1,48 @@
+From e77eb9597c4c094a0b0bbeef0b957b49b40b87eb Mon Sep 17 00:00:00 2001
+From: Wez Furlong <wez@fb.com>
+Date: Mon, 8 Jan 2018 21:57:43 -0800
+Subject: [PATCH] fix art.t test failure on alpine linux
+
+Summary:
+Looks like we end up with root_ holding a nullptr after
+the associated test is finished. This only seems to be a problem
+in practice on Alpine linux's musl libc based environment, and
+only when built with `-O2`. Not sure if this is a c++ standard
+library implementation issue or a compiler optimization, or a
+combination of both of those things.
+
+Guard against that with a simple nullptr check.
+
+Refs https://github.com/facebook/watchman/issues/546
+
+Reviewed By: simpkins
+
+Differential Revision: D6681244
+
+fbshipit-source-id: f119b3552c0aeedc325fa83c71b12745536b1dac
+---
+ thirdparty/libart/src/art-inl.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/thirdparty/libart/src/art-inl.h b/thirdparty/libart/src/art-inl.h
+index fce055be..acc7cd67 100644
+--- a/thirdparty/libart/src/art-inl.h
++++ b/thirdparty/libart/src/art-inl.h
+@@ -760,7 +760,7 @@ art_tree<ValueType, KeyType>::Node::maximum() const {
+ template <typename ValueType, typename KeyType>
+ typename art_tree<ValueType, KeyType>::Leaf*
+ art_tree<ValueType, KeyType>::minimum() const {
+- return root_->minimum();
++ return root_ ? root_->minimum() : nullptr;
+ }
+
+ /**
+@@ -769,7 +769,7 @@ art_tree<ValueType, KeyType>::minimum() const {
+ template <typename ValueType, typename KeyType>
+ typename art_tree<ValueType, KeyType>::Leaf*
+ art_tree<ValueType, KeyType>::maximum() const {
+- return root_->maximum();
++ return root_ ? root_->maximum() : nullptr;
+ }
+
+ template <typename ValueType, typename KeyType>