aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/rawtherapee/APKBUILD (renamed from unmaintained/rawtherapee/APKBUILD)18
-rw-r--r--community/rawtherapee/c++11.patch28
-rw-r--r--community/rawtherapee/sigc++.patch52
3 files changed, 94 insertions, 4 deletions
diff --git a/unmaintained/rawtherapee/APKBUILD b/community/rawtherapee/APKBUILD
index 1bcc428463..d5c9e805ef 100644
--- a/unmaintained/rawtherapee/APKBUILD
+++ b/community/rawtherapee/APKBUILD
@@ -15,7 +15,10 @@ makedepends="bzip2-dev exiv2-dev expat-dev fftw-dev glib-dev gtk+2.0-dev \
libiptcdata-dev libjpeg-turbo-dev"
install=""
subpackages="$pkgname-doc"
-source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver}.tar.xz"
+source="http://rawtherapee.com/shared/source/${pkgname}-${pkgver}.tar.xz
+ sigc++.patch
+ c++11.patch
+ "
_builddir=${srcdir}/${pkgname}-${pkgver}
prepare() {
@@ -30,6 +33,7 @@ prepare() {
build() {
cd "$_builddir"
+ export CXXFLAGS="$CXXFLAGS -std=c++11"
cmake -DCMAKE_INSTALL_PREFIX=/usr || return 1
make
}
@@ -39,6 +43,12 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="e6510ed56fdc35aa712b4c0f54c52ac0 rawtherapee-4.2.tar.xz"
-sha256sums="fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 rawtherapee-4.2.tar.xz"
-sha512sums="feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 rawtherapee-4.2.tar.xz"
+md5sums="e6510ed56fdc35aa712b4c0f54c52ac0 rawtherapee-4.2.tar.xz
+63dc8bf5dd7468a12fba75805fb6520d sigc++.patch
+5fa63cca42b2af2cd6cddab3e8dfd786 c++11.patch"
+sha256sums="fa4c13e8842df096b19d2dabaed5a61f5f9d4547f7b4f0dc6b77f80bdec16479 rawtherapee-4.2.tar.xz
+d57361e6bdb0386ca84b4c25b7aed0b4b6659035f72178a6f8cb6f9031672c90 sigc++.patch
+9a63bd8d0c0149bf48e33441b5f0e2c163bfcd9c3204a6d353c054eb69e7bcb6 c++11.patch"
+sha512sums="feec61aeb84804cf01ff03fa9d7309f0eb3c04c43818c8397cc6f3ee762aca19484bce7594414d2141248b9740bdd4269fd86f76dcf391c61d4647fa169d48f6 rawtherapee-4.2.tar.xz
+bce6c8b1f02ff335ef10fff7decc61f21c5c8cea251fe703d9fc50616d3113f0439cd05b06aa698849f4356afa63ddf19d0a5d2f39df7ff73406a3e243cafb09 sigc++.patch
+81a403b999e5aa9e2e91445734950ac01de7daab3c21569cad78c7bb54d43e7db9340320e556d8bc3f12c4903bc66852e17306e3b73e0744d02d7c2ff32ad239 c++11.patch"
diff --git a/community/rawtherapee/c++11.patch b/community/rawtherapee/c++11.patch
new file mode 100644
index 0000000000..86a6ff0717
--- /dev/null
+++ b/community/rawtherapee/c++11.patch
@@ -0,0 +1,28 @@
+From c6620b415db72cbdf8833476a21af5190e15fa22 Mon Sep 17 00:00:00 2001
+From: Marcin Bajor <marcin.bajor@gmail.com>
+Date: Wed, 14 Oct 2015 10:51:27 +0200
+Subject: [PATCH] Fix for build with C++11 flags
+
+---
+ rtengine/dcraw.cc | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/rtengine/dcraw.cc b/rtengine/dcraw.cc
+index add5b52..8e0a36d 100644
+--- a/rtengine/dcraw.cc
++++ b/rtengine/dcraw.cc
+@@ -136,10 +136,10 @@ const float d65_white[3] = { 0.950456, 1, 1.088754 };
+
+ #define SQR(x) rtengine::SQR(x)
+ #define ABS(x) (((int)(x) ^ ((int)(x) >> 31)) - ((int)(x) >> 31))
+-#define MIN(a,b) rtengine::min(a,static_cast<typeof(a)>(b))
+-#define MAX(a,b) rtengine::max(a,static_cast<typeof(a)>(b))
+-#define LIM(x,min,max) rtengine::LIM(x,static_cast<typeof(x)>(min),static_cast<typeof(x)>(max))
+-#define ULIM(x,y,z) rtengine::ULIM(x,static_cast<typeof(x)>(y),static_cast<typeof(x)>(z))
++#define MIN(a,b) rtengine::min(a,static_cast<__typeof__(a)>(b))
++#define MAX(a,b) rtengine::max(a,static_cast<__typeof__(a)>(b))
++#define LIM(x,min,max) rtengine::LIM(x,static_cast<__typeof__(x)>(min),static_cast<__typeof__(x)>(max))
++#define ULIM(x,y,z) rtengine::ULIM(x,static_cast<__typeof__(x)>(y),static_cast<__typeof__(x)>(z))
+ #define CLIP(x) rtengine::CLIP(x)
+ #define SWAP(a,b) { a=a+b; b=a-b; a=a-b; }
+
diff --git a/community/rawtherapee/sigc++.patch b/community/rawtherapee/sigc++.patch
new file mode 100644
index 0000000000..eeeefb733d
--- /dev/null
+++ b/community/rawtherapee/sigc++.patch
@@ -0,0 +1,52 @@
+diff --git a/rtgui/adjuster.cc b/rtgui/adjuster.cc
+index f73dd8a..a7a069c 100644
+--- a/rtgui/adjuster.cc
++++ b/rtgui/adjuster.cc
+@@ -17,7 +17,7 @@
+ * along with RawTherapee. If not, see <http://www.gnu.org/licenses/>.
+ */
+ #include "adjuster.h"
+-#include <sigc++/class_slot.h>
++#include <sigc++/slot.h>
+ #include <cmath>
+ #include "multilangmgr.h"
+ #include "../rtengine/rtengine.h"
+diff --git a/rtgui/preferences.cc b/rtgui/preferences.cc
+index 134c0d7..8ce1808 100644
+--- a/rtgui/preferences.cc
++++ b/rtgui/preferences.cc
+@@ -16,7 +16,7 @@
+ * You should have received a copy of the GNU General Public License
+ * along with RawTherapee. If not, see <http://www.gnu.org/licenses/>.
+ */
+-#include <sigc++/class_slot.h>
++#include <sigc++/slot.h>
+ #include "preferences.h"
+ #include "multilangmgr.h"
+ #include "splash.h"
+diff --git a/rtgui/thresholdadjuster.cc b/rtgui/thresholdadjuster.cc
+index 6b41329..19cde25 100644
+--- a/rtgui/thresholdadjuster.cc
++++ b/rtgui/thresholdadjuster.cc
+@@ -17,7 +17,7 @@
+ * along with RawTherapee. If not, see <http://www.gnu.org/licenses/>.
+ */
+ #include "thresholdadjuster.h"
+-#include <sigc++/class_slot.h>
++#include <sigc++/slot.h>
+ #include <cmath>
+ #include "multilangmgr.h"
+ #include "../rtengine/rtengine.h"
+diff --git a/rtgui/tonecurve.cc b/rtgui/tonecurve.cc
+index 2e439e1..5f14200 100644
+--- a/rtgui/tonecurve.cc
++++ b/rtgui/tonecurve.cc
+@@ -18,7 +18,7 @@
+ */
+ #include "tonecurve.h"
+ #include "adjuster.h"
+-#include <sigc++/class_slot.h>
++#include <sigc++/slot.h>
+ #include <iomanip>
+ #include "ppversion.h"
+ #include "edit.h"