aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/gifsicle/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/gifsicle/APKBUILD b/community/gifsicle/APKBUILD
index 69dd66823f..806d42f8af 100644
--- a/community/gifsicle/APKBUILD
+++ b/community/gifsicle/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=gifsicle
pkgver=1.91
-pkgrel=0
-pkgdesc="Command-line tool for making, editing, and getting information about GIF animations"
+pkgrel=1
+pkgdesc="Command-line tool for making, editing and getting information about GIF animations"
url="http://www.lcdf.org/gifsicle/"
arch="all"
license="GPL-2.0"
makedepends="libx11-dev libice-dev libsm-dev"
+checkdepends="perl"
subpackages="$pkgname-doc"
source="http://www.lcdf.org/gifsicle/gifsicle-$pkgver.tar.gz"
-builddir="$srcdir"/gifsicle-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -26,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install