aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/thermald/APKBUILD2
-rw-r--r--testing/thermald/ppc64le.patch33
2 files changed, 33 insertions, 2 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index f29c514ff2..8e9e32bafd 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -44,4 +44,4 @@ package() {
sha512sums="71fa6e9fc2f55623ed0acdb65f9699d5ea2c89c4092546a73d53ac3ea3ca0a5c60f3360c8bef0af9daeeecfe9a20411d9e4d25bc1d89349cfe83ebb03ba387a8 thermald-1.9.tar.gz
ea8964b15fdebc2fb59e93c15b813b93691c2ba01689ac6080f1308a3063b23cba56b4539ccae87575689036f74300a1c22c9b0e77d4ecef9bc08198d7fe4892 thermald.initd
ea72002dcdfa907964f2ffc28947d8b2b536a93876d65872085aa9ebf2bdb549fae9c43412d74590ad88d2d71c48067726cc755630c41e30d77eb9c0c56d7308 no-werror.patch
-789d1fa0411339b12bebfb55c3e21ba19aa3cabd94d2345c680af34d2b776c473b33871d46ff9021431cd42eea0b3626fb5c9a8b7137da17177c5918d2dea8a3 ppc64le.patch"
+0700af8160d6953e5144feba252592aaa03d8aa0a3be51e90fcab31924d728998cffd970bba9f4fc9d64819cb050fe66b99d6490c077b4a8cc152926964c90e0 ppc64le.patch"
diff --git a/testing/thermald/ppc64le.patch b/testing/thermald/ppc64le.patch
index 537f1503b6..52ca3adcaf 100644
--- a/testing/thermald/ppc64le.patch
+++ b/testing/thermald/ppc64le.patch
@@ -1,5 +1,5 @@
diff --git a/src/thd_engine.cpp b/src/thd_engine.cpp
-index 82882dd..6efd7cb 100644
+index 82882dd..64e4db2 100644
--- a/src/thd_engine.cpp
+++ b/src/thd_engine.cpp
@@ -35,7 +35,9 @@
@@ -12,4 +12,35 @@ index 82882dd..6efd7cb 100644
#include <locale>
#include "thd_engine.h"
#include "thd_cdev_therm_sys_fs.h"
+@@ -664,7 +666,7 @@ static supported_ids_t id_table[] = {
+ #endif
+
+ int cthd_engine::check_cpu_id() {
+-#ifndef ANDROID
++#ifndef ANDROID && !defined(__powerpc__)
+ // Copied from turbostat program
+ unsigned int ebx, ecx, edx, max_level;
+ unsigned int fms, family, model, stepping;
+diff --git a/src/thd_engine_default.cpp b/src/thd_engine_default.cpp
+index 3454170..e75fdaf 100644
+--- a/src/thd_engine_default.cpp
++++ b/src/thd_engine_default.cpp
+@@ -795,14 +795,16 @@ void cthd_engine_default::workarounds()
+ }
+
+ #ifndef ANDROID
++#ifndef __powerpc__
+ #include <cpuid.h>
++#endif
+ #include <sys/mman.h>
+ #define BIT_ULL(nr) (1ULL << (nr))
+ #endif
+
+ void cthd_engine_default::workaround_rapl_mmio_power(void)
+ {
+-#ifndef ANDROID
++#ifndef ANDROID && !defined(__powerpc__)
+ int map_fd;
+ void *rapl_mem;
+ unsigned char *rapl_pkg_pwr_addr;