aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/cunit/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/community/cunit/APKBUILD b/community/cunit/APKBUILD
index 7433118af3..902129812e 100644
--- a/community/cunit/APKBUILD
+++ b/community/cunit/APKBUILD
@@ -4,12 +4,11 @@ pkgname=cunit
_pkgname=CUnit
pkgver=2.1.3
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=0
+pkgrel=1
pkgdesc="Automated testing framework for C"
url="http://cunit.sourceforge.net/"
arch="all"
license="GPL2"
-options="!check"
makedepends="automake autoconf libtool bash"
subpackages="$pkgname-dev $pkgname-doc"
source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
@@ -17,6 +16,7 @@ source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_
builddir="$srcdir/$_pkgname-$_pkgver"
prepare() {
+ default_prepare
cd "$builddir"
libtoolize --force --copy
aclocal
@@ -27,7 +27,6 @@ prepare() {
build() {
cd "$builddir"
- default_prepare
./configure \
--prefix=/usr \
--includedir=/usr/include \
@@ -42,6 +41,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install