aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/llvm-libunwind/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/llvm-libunwind/APKBUILD b/testing/llvm-libunwind/APKBUILD
index bcd90ea19e..3168e5a33c 100644
--- a/testing/llvm-libunwind/APKBUILD
+++ b/testing/llvm-libunwind/APKBUILD
@@ -4,10 +4,10 @@ pkgname=llvm-libunwind
_pkgname=libunwind
pkgver=3.9.1
_llvmver=3.9
-pkgrel=0
+pkgrel=1
pkgdesc="LLVM version of libunwind library"
url="http://llvm.org/"
-arch="all !x86"
+arch="all"
license="BSD"
depends_dev="!libunwind-dev"
makedepends="cmake llvm$_llvmver-dev"
@@ -28,6 +28,7 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DLIBUNWIND_ENABLE_SHARED=$flag \
+ -DLIBUNWIND_HAS_NODEFAULTLIBS_FLAG=0 \
-DLLVM_CONFIG="/usr/bin/llvm-config-$_llvmver"
make
done