aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/jool-modules-vanilla/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/testing/jool-modules-vanilla/APKBUILD b/testing/jool-modules-vanilla/APKBUILD
index 144467736e..4776bfecb5 100644
--- a/testing/jool-modules-vanilla/APKBUILD
+++ b/testing/jool-modules-vanilla/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer:
-# jool version
-# when changing _ver we *must* bump _rel!
+# Jool version
+# Keep in sync with testing/jool-tools!
+# When changing _ver we *must* bump _rel!
_name=jool-modules
_ver=4.0.6
_rel=0
-# for custom kernels set $FLAVOR
+# For custom kernels set $FLAVOR.
_flavor="$FLAVOR"
_extra_flavors=""
if [ -z "$FLAVOR" ]; then
@@ -17,18 +18,17 @@ if [ -z "$FLAVOR" ]; then
esac
fi
-# kernel verson
+# Kernel version
+# Keep in sync with main/linux-vanilla!
_kpkg=linux-$_flavor
_kver=4.19.80
_krel=0
-
_kpkgver="$_kver-r$_krel"
-_kabi="$_kver-$_krel-$_flavor"
pkgname=$_name-$_flavor
pkgver=$_kver
pkgrel=$(( $_krel + $_rel ))
-pkgdesc="SIIT and NAT64 for Linux (kernel modules for $_flavor)"
+pkgdesc="SIIT and NAT64 for Linux (kernel modules for linux-$_flavor)"
url="https://jool.mx"
arch="all"
license="GPL-2.0-or-later"
@@ -38,7 +38,7 @@ install_if="$_kpkg=$_kpkgver $_name"
subpackages=""
source="https://github.com/NICMx/Jool/releases/download/v$_ver/jool-$_ver.tar.gz"
builddir="$srcdir/jool-$_ver"
-options="!check"
+options="!check" # no tests provided
for _f in $_extra_flavors; do
makedepends="$makedepends linux-$_f-dev=$_kpkgver"
@@ -78,7 +78,7 @@ _extra() {
local flavor=${subpkgname##*-}
depends="linux-$flavor=$_kpkgver"
install_if="linux-$flavor=$_kpkgver $_name"
- pkgdesc="SIIT and NAT64 for Linux (kernel modules for $flavor)"
+ pkgdesc="SIIT and NAT64 for Linux (kernel modules for linux-$flavor)"
_modules_install "$flavor" "$subpkgdir"
}