aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/xf86-video-ati/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/main/xf86-video-ati/APKBUILD b/main/xf86-video-ati/APKBUILD
index 7fbe0e7c26..13c7109c81 100644
--- a/main/xf86-video-ati/APKBUILD
+++ b/main/xf86-video-ati/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-ati
-pkgver=7.9.0
+pkgver=7.10.0
pkgrel=0
pkgdesc="ATI video driver"
url="http://xorg.freedesktop.org/"
@@ -10,12 +10,11 @@ subpackages="$pkgname-doc"
depends="mesa-dri-ati"
makedepends="xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto libdrm-dev xf86driproto glproto mesa-dev
- xineramaproto eudev-dev pixman-dev
- "
-
-source="http://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
- "
+ xineramaproto eudev-dev pixman-dev"
+options="!check"
+source="http://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
+
build() {
cd "$builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
@@ -24,14 +23,14 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-glamor \
- || return 1
- make || return 1
+ --disable-glamor
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="125e035da6581520d677c56474653ed75aa6d168bf5450cc973248416b5ada3114ea14d0615b44c58029bb1702609453ab532a506273df2a5dd99dd2af4a9d43 xf86-video-ati-7.9.0.tar.bz2"
+
+sha512sums="1f2f4af1d299af62644693e6fbc47a5078c9bc5e7887a1ac217121ef2fd29d8c9f50a8d9be9ddb0887d0b49141bb33484f82c1313a472ad6867266b53b4a11ad xf86-video-ati-7.10.0.tar.bz2"