aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-freezegun/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-freezegun/APKBUILD b/testing/py3-freezegun/APKBUILD
new file mode 100644
index 0000000000..2ae03fee62
--- /dev/null
+++ b/testing/py3-freezegun/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Robert Sacks <robert@sacks.email>
+# Maintainer: Robert Sacks <robert@sacks.email>
+pkgname=py3-freezegun
+_pyname=freezegun
+pkgver=0.3.12
+pkgrel=0
+pkgdesc="Let your Python tests travel through time"
+url="https://pypi.org/project/freezegun/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-dateutil py3-six"
+makedepends="py3-setuptools"
+checkdepends="py3-mock py3-pytest py3-nose"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ rm -f tests/test_uuid.py
+ pytest-3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f7d98ea84735b24380fa53e1e62622fe91be5a35cb75221ca4cb02418add9b0a4add9b2f691242be75acbc45d4745fef82ffe3c89890dcdffa4405940e527af4 freezegun-0.3.12.tar.gz"