aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/rust/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index 73b358534f..2295562388 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -13,7 +13,7 @@ license="ASL-2.0 BSD ISC MIT"
# gcc is needed at runtime just for linking. Someday rustc might invoke
# the linker directly, and then we'll only need binutils.
# See: https://github.com/rust-lang/rust/issues/11937
-depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc"
+depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc musl-dev"
# libffi-dev is needed just because we compile llvm with LLVM_ENABLE_FFI.
makedepends="cmake file libffi-dev libunwind-dev llvm llvm-dev
musl-dev python2 tar zlib-dev"
@@ -117,6 +117,9 @@ package() {
# them. Read change-rpath-to-rustlib.patch for more info.
rm -r usr/lib/*.so
+ # These objects are for static linking with musl on non-musl systems.
+ rm $_rlibdir/crt*.o
+
# Shared objects should have executable flag.
chmod +x $_rlibdir/*.so