aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/xpra/APKBUILD28
-rw-r--r--testing/xpra/fix-xdummy-musl-detect.patch19
2 files changed, 8 insertions, 39 deletions
diff --git a/testing/xpra/APKBUILD b/testing/xpra/APKBUILD
index 30e3ee7e75..8046a8ddc3 100644
--- a/testing/xpra/APKBUILD
+++ b/testing/xpra/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=xpra
-pkgver=0.16.3
+pkgver=0.17.1
pkgrel=0
pkgdesc="Xpra is 'screen for X' & allows you to run X programs, usually on a remote host over SSH or encrypted tcp."
url="http://xpra.org"
@@ -9,14 +9,11 @@ arch="all"
license="GPLv2+"
depends="py-gobject py-gtk py-imaging xf86-video-dummy xvfb setxkbmap xorg-server py-numpy py-pillow py-gtkglext py-lz4 \
py-rencode py-opencl"
-# cython only depends until cython patch applies
-depends_dev="python-dev cython-dev cython libx11-dev libxtst-dev libxcomposite-dev libxdamage-dev libxrandr-dev
+depends_dev="python-dev cython-dev libx11-dev libxtst-dev libxcomposite-dev libxdamage-dev libxrandr-dev \
py-gobject-dev py-gtk-dev libxkbfile-dev gtk+2.0-dev x264-dev x265-dev libvpx-dev ffmpeg-dev libwebp-dev"
-makedepends="$depends_dev cython"
+makedepends="$depends_dev cython linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tests"
-source="http://xpra.org/src/$pkgname-$pkgver.tar.xz
- fix-xdummy-musl-detect.patch
- "
+source="http://xpra.org/src/$pkgname-$pkgver.tar.xz"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -32,13 +29,6 @@ prepare() {
build() {
cd "$_builddir" # https://www.xpra.org/trac/ticket/1080
CFLAGS="$CFLAGS -fno-strict-aliasing"
- # dummy patch applied in http://xpra.org/trac/changeset/12475/xpra
- # sed fix applied in http://xpra.org/trac/changeset/12471/xpra
- sed -i setup.py \
- -e '/GDK_BINDINGS_PACKAGES = PYGTK_PACKAGES/s/"xfixes"/"x11", "xext", "xfixes"/' \
- -e 's/pkgconfig("xtst", "xfixes", "xcomposite", "xdamage", "xext")\
- /pkgconfig("x11", "xtst", "xfixes", "xcomposite", "xdamage", "xext")/' \
- -e 's/pkgconfig("xcomposite", "xdamage", "xext")/pkgconfig("x11", "xcomposite", "xdamage", "xext")/'
python setup.py build \
--with-csc_opencl \
--with-bundle_tests \
@@ -51,14 +41,12 @@ package() {
}
tests() {
+ arch="noarch"
cd "$_builddir"
mkdir -p "$subpkgdir"/usr/share/xpra
cp -rf tests "$subpkgdir"/usr/share/xpra/
}
-md5sums="9f81ac22991083ee49e01f62ae113a56 xpra-0.16.3.tar.xz
-b19a1fd26e94be8db372c8555152218d fix-xdummy-musl-detect.patch"
-sha256sums="1516ab10eb348092077ffb698bce234d06a234a5748e422fdf92f34922fb39ea xpra-0.16.3.tar.xz
-eb88db7301a30441b710f38028f316f90e8cd3af213468d96a5d04d5c64a69ef fix-xdummy-musl-detect.patch"
-sha512sums="1a6bbd01837e702e98ffcaffe12a2e5320108ef50f0fcc64a80735fb53a2b41e4cdda0e0a2d1a3b5f2159a81da4a7c2cac458ab4c2eed4de17adb4e963218590 xpra-0.16.3.tar.xz
-0ddc4a4359cc257a77445b4bc747bdb79ae8f049078c9dcb531fc41555e8d74842cf599edbd29a2f13bd977a20922df6ab4e51839dba7d4aae865897f2b872fc fix-xdummy-musl-detect.patch"
+md5sums="d83910c4e8c3799822f5fe90f6d8e928 xpra-0.17.1.tar.xz"
+sha256sums="041de13937f3f0529dcde9ccc681b52bc85c5074a021060a56a1da2cdfe66315 xpra-0.17.1.tar.xz"
+sha512sums="f1d323b7207b89838045126939d7d68ff72313c00724f2be7d405c12880fedc12900c11c8d36a0780ee6f7ffca1b6f75c69136eeebd73333fbd437cf9a7ffcfa xpra-0.17.1.tar.xz"
diff --git a/testing/xpra/fix-xdummy-musl-detect.patch b/testing/xpra/fix-xdummy-musl-detect.patch
deleted file mode 100644
index cacd7d074a..0000000000
--- a/testing/xpra/fix-xdummy-musl-detect.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- xpra-0.16.3/scripts/xpra_Xdummy
-+++ xpra-0.16.3/scripts/xpra_Xdummy.new
-@@ -30,8 +30,14 @@
- fi
-
- if [ ! -x "$LD_LINUX" ]; then
-- LD_LINUX=''
-- echo "could not determine ld path for $arch, please file an xpra bug"
-+ # Musl C / Alpine Linux
-+ ldmusl=$(ls /lib | grep ^ld-musl)
-+ if [ -n "$ldmusl" ]; then
-+ LD_LINUX="/lib/$ldmusl"
-+ else
-+ LD_LINUX=''
-+ echo "could not determine ld path for $arch, please file an xpra bug"
-+ fi
- fi
- }
-