aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/firefox-esr/APKBUILD26
1 files changed, 3 insertions, 23 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index ee57b1985f..532f08fd59 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -211,6 +211,8 @@ build() {
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
+ # Find our triplet JSON
+ export RUST_TARGET="$CTARGET"
# gcc 6
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
@@ -218,31 +220,9 @@ build() {
export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
case "$CARCH" in
- x86)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="i686-unknown-linux-musl"
- ;;
- x86_64)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="$CTARGET"
- ;;
- aarch64)
- export RUST_TARGET="aarch64-unknown-linux-musl"
- ;;
- armv7)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="armv7-unknown-linux-musleabihf"
- ;;
- armhf)
+ arm*|x86*)
# disable-elf-hack: exists only on arm, x86, x86_64
_arch_config="--disable-elf-hack"
- export RUST_TARGET="arm-unknown-linux-musleabihf"
- ;;
- ppc64le)
- export RUST_TARGET="powerpc64le-unknown-linux-musl"
;;
esac