aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-04-09 16:05:42 +0200
committerMilan P. Stanić <mps@arvanta.net>2020-04-09 16:05:42 +0200
commit8a564a86c28f5c610bd0d77ef7202892e61486de (patch)
treeb1c9d81be5949b8a07b664bd1b19d24f750f6585
parentbfd07de95c94f6e6d79f26360f891a17e8aac1c4 (diff)
downloadaports-8a564a86c28f5c610bd0d77ef7202892e61486de.tar.bz2
aports-8a564a86c28f5c610bd0d77ef7202892e61486de.tar.xz
community/firefox-esr: use our new Rust triplets
picked from git commit bfd07de95c94f6e6d79f26360f891a17e8aac1c4 made by Rasmus Thomsen <oss@cogitri.dev>
-rw-r--r--community/firefox-esr/APKBUILD26
1 files changed, 3 insertions, 23 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index ee57b1985f..532f08fd59 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -211,6 +211,8 @@ build() {
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
+ # Find our triplet JSON
+ export RUST_TARGET="$CTARGET"
# gcc 6
export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
@@ -218,31 +220,9 @@ build() {
export LDFLAGS="$LDFLAGS -Wl,-rpath,$_mozappdir"
case "$CARCH" in
- x86)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="i686-unknown-linux-musl"
- ;;
- x86_64)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="$CTARGET"
- ;;
- aarch64)
- export RUST_TARGET="aarch64-unknown-linux-musl"
- ;;
- armv7)
- # disable-elf-hack: exists only on arm, x86, x86_64
- _arch_config="--disable-elf-hack"
- export RUST_TARGET="armv7-unknown-linux-musleabihf"
- ;;
- armhf)
+ arm*|x86*)
# disable-elf-hack: exists only on arm, x86, x86_64
_arch_config="--disable-elf-hack"
- export RUST_TARGET="arm-unknown-linux-musleabihf"
- ;;
- ppc64le)
- export RUST_TARGET="powerpc64le-unknown-linux-musl"
;;
esac