aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/kimchi/APKBUILD31
-rw-r--r--testing/kimchi/systemd-substitution-with-openrc.patch8
2 files changed, 20 insertions, 19 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index 917c1cb6e9..9d92077acf 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -1,24 +1,25 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kimchi
-pkgver=2.3.1
-pkgrel=2
+pkgver=2.4.0
+pkgrel=0
pkgdesc="An HTML5 management interface for KVM "
url="https://github.com/kimchi-project/kimchi"
arch="noarch"
license="APACHE LGPL2.1"
depends="python2 py-ipaddr py2-m2crypto py2-simplejson py-psutil
-py-imaging py2-libvirt py-cheetah py-ethtool py2-lxml py-websockify
-py2-pillow qemu py2-configobj py2-six py2-paramiko py2-magic libvirt-daemon
-wok gingerbase py2-netaddr py2-libuser
-util-linux spice-html5 websockify py-numpy"
+ py-imaging py2-libvirt py-cheetah py-ethtool py2-lxml py-websockify
+ py2-pillow qemu py2-configobj py2-six py2-paramiko py2-magic libvirt-daemon
+ wok gingerbase py2-netaddr py2-libuser
+ util-linux spice-html5 websockify py-numpy"
makedepends="automake autoconf libtool gettext-dev
-python2-dev py-setuptools pyflakes libxslt py2-pip
-py-pep8 py2-mock py-cherrypy pytest py2-requests
-grep bash bc spice-html5"
+ python2-dev py-setuptools pyflakes libxslt py2-pip
+ py-pep8 py2-mock py-cherrypy pytest py2-requests
+ grep bash bc spice-html5"
+options="!check"
subpackages="$pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
-systemd-substitution-with-openrc.patch"
+ systemd-substitution-with-openrc.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -29,7 +30,7 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--with-spice-html5
- make -j1 || return 1
+ make -j1
}
package() {
@@ -37,9 +38,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="3312e6158c5bde8be3e499b6b4488751 kimchi-2.3.1.tar.gz
-c46ad325d11ed135a3bea6ddcb688faa systemd-substitution-with-openrc.patch"
-sha256sums="81da6381480d2a69eb6cf073b1e0f7c9288d13c2f34f90dabf3568ce089d15d0 kimchi-2.3.1.tar.gz
-afaa9128c4d2f21e717ef1c059eb7a14cd5802ac55c4d7fa696ecb2260043755 systemd-substitution-with-openrc.patch"
-sha512sums="2db03e66277df6d7d66dae25e6663e32eba791dca563d7bef02d394f8352cca2dbd1a904c76f0ae0b3a1ca2593c7fcb99be3877f658a22b54cd79e2b332d8b74 kimchi-2.3.1.tar.gz
-b4ec58de87d26e8f342c5f78818a96a3c7cbb8de979a7e9fa9b3ececbc98775d435e065dc41023968efa919f3ed1636c4409420d1f55f4ddb94dd4b9a573399f systemd-substitution-with-openrc.patch"
+sha512sums="d51fa52b420cc6b775225e410fa7f222700d351cccca8eb0fda492bf4973c1808f3bf13d5a01a825b2163124c8925ffba810ec80f0110c9978e4566bdc9b2733 kimchi-2.4.0.tar.gz
+a78c51237233b629c84106cfcdc8398a030889dd8bc641630a8c4e05fdad8d32a9b457c36188e1752a1277ef884437c1765c897bc2a33ca87c07e3bafdfdd5bf systemd-substitution-with-openrc.patch"
diff --git a/testing/kimchi/systemd-substitution-with-openrc.patch b/testing/kimchi/systemd-substitution-with-openrc.patch
index 0ca2ff19a9..b05f545530 100644
--- a/testing/kimchi/systemd-substitution-with-openrc.patch
+++ b/testing/kimchi/systemd-substitution-with-openrc.patch
@@ -1,8 +1,8 @@
diff --git a/utils.py b/utils.py
-index 1e2c951..459c76f 100644
+index 22430ce..2ec4845 100644
--- a/utils.py
+++ b/utils.py
-@@ -263,6 +263,7 @@ def is_libvirtd_up():
+@@ -265,9 +265,11 @@ def is_libvirtd_up():
"""
Checks if libvirtd.service is up.
"""
@@ -12,3 +12,7 @@ index 1e2c951..459c76f 100644
output, error, rc = run_command(cmd, silent=True)
- return True if output == 'active\n' else False
+ return True if "started" in output else False
++
+
+
+ def is_s390x():